Modify

Opened 4 years ago

Last modified 3 years ago

#11008 reopened enhancement

Several problems/enhancement of changeset manager

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report changeset manager Cc:

Description (last modified by simon04)

What steps will reproduce the problem?

  1. Under properties tab there is twice the same icon on the lower left panel → comment:6
    • do not really understand but think one got mixed up.
  2. Help button does not work though wiki:Help/Dialog/ChangesetManager exists fixed r7982
  3. There is no possibility to download any object fixed in #4996
    • At least still existing objects could be downloaded through content menu under the content tab with room to enhance.

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-01-22 02:34:20
Last Changed Author: Klumbumbus
Revision: 7978
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-01-22 01:10:40 +0100 (Thu, 22 Jan 2015)
Last Changed Rev: 7978

Identification: JOSM/1.5 (7978 en) Linux Debian GNU/Linux 7.8 (wheezy)
Memory Usage: 418 MB / 882 MB (168 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u71-2.5.3-2~deb7u1
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30892)
- conflation (0.1.7)
- download_along (30892)
- imagery-xml-bounds (30892)
- imagery_offset_db (30892)
- jts (30892)
- mirrored_download (30892)
- photoadjust (30905)
- reverter (30892)
- terracer (30892)
- todo (29154)
- undelete (30892)
- utilsplugin2 (30892)
- waydownloader (30892)
- wikipedia (30892)

Attachments (1)

icontwice.gif (6.2 MB) - added by Klumbumbus 3 years ago.

Change History (16)

comment:1 in reply to:  description ; Changed 4 years ago by Don-vip

Replying to skyper:

  1. Under properties tab there is twice the same icon on the lower left panel

please attach a screenshot for this point as I cannot reproduce

comment:2 Changed 4 years ago by Don-vip

In 7982/josm:

see #11008 - fix changeset manager help button

comment:3 in reply to:  1 Changed 4 years ago by skyper

Replying to Don-vip:

Replying to skyper:

  1. Under properties tab there is twice the same icon on the lower left panel

please attach a screenshot for this point as I cannot reproduce

Strange I did restart JOSM in between and I cannot reproduce either. It was the third icon from top with the green arrow which was missing and instead the one with the two, blue arrows was shown twice.

Maybe a caching problem ?

Last edited 4 years ago by skyper (previous) (diff)

comment:4 Changed 4 years ago by skyper

Description: modified (diff)

comment:5 in reply to:  description Changed 3 years ago by simon04

Milestone: 16.02
Resolution: fixed
Status: newclosed

Replying to skyper:

  1. There is no possibility to download any object
    • At least still existing objects could be downloaded through content menu under the content tab with room to enhance.

#4996

Changed 3 years ago by Klumbumbus

Attachment: icontwice.gif added

comment:6 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

See attached gif, how to reproduce the switching icon. Also the mouseover hint changes. I did not yet really work with the changeset manager, so I don't know if this is a feature or a bug.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-18 01:46:48 +0100 (Mon, 18 Jan 2016)
Build-Date:2016-01-18 02:34:44
Revision:9524
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9524 en) Windows 7 32-Bit
Memory Usage: 247 MB / 742 MB (82 MB allocated, but free)
Java version: 1.8.0_66-b18, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre1.8.0_66\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files\josm-latest-bla.jnlp, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=256m,768m, -Djnlpx.splashport=62225, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31772)
- DirectDownload (31934)
- DirectUpload (31912)
- HouseNumberTaggingTool (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- RoadSigns (31895)
- apache-commons (31895)
- buildings_tools (31895)
- download_along (31772)
- editgpx (31772)
- imagery_offset_db (31895)
- importvec (31772)
- log4j (31895)
- measurement (31895)
- photo_geotagging (31895)
- photoadjust (31963)
- public_transport (31895)
- reltoolbox (31895)
- reverter (31926)
- tag2link (31910)
- tageditor (31772)
- tagging-preset-tester (31895)
- terracer (31895)
- turnlanes (31772)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (31895)
- wikipedia (32003)

comment:7 Changed 3 years ago by stoecker

It's a buggy feature. :-)

As far as I see the icon change indicates, that the "contents" of the changeset is now downloaded and can be refreshed (maybe another icon would be fine to differentiate from the one above - only red squares with the blue arrows, no box around?).

Question is why refresh of the header (upper icon) causes loss of the contents?

Last edited 3 years ago by stoecker (previous) (diff)

comment:8 Changed 3 years ago by simon04

Description: modified (diff)

comment:9 Changed 3 years ago by Don-vip

Milestone: 16.0216.03

comment:10 Changed 3 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

comment:11 Changed 3 years ago by Don-vip

Milestone: 16.0416.05

comment:12 Changed 3 years ago by Don-vip

Milestone: 16.0516.06

comment:13 Changed 3 years ago by Don-vip

Milestone: 16.0616.07

comment:14 Changed 3 years ago by Don-vip

Milestone: 16.0716.08

comment:15 Changed 3 years ago by Don-vip

Milestone: 16.08

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to skyper
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.