Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#10991 closed enhancement (fixed)

Add relation type = route / route = foot to default preset

Reported by: Gilbert54 Owned by: team
Priority: normal Milestone: 16.02
Component: Internal preset Version: tested
Keywords: template_report route foot hiking Cc: wernerschka

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. select route 3231956
  2. validate the object

What is the expected result?

Validation OK

What happens instead?

Relation type is unknown. According to wiki:

route=foot is used for routes which are walking and/or do not match "hiking" (WP's definition of hiking: "a long, vigorous walk, usually on trails, in the countryside").

Please provide any additional information below. Attach a screenshot if possible.

screenshot

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-12-29 00:11:17
Last Changed Author: Don-vip
Revision: 7906
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-12-29 00:13:58 +0100 (Mon, 29 Dec 2014)
Last Changed Rev: 7906

Identification: JOSM/1.5 (7906 en_GB) Windows 7 64-Bit
Memory Usage: 910 MB / 910 MB (531 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- HouseNumberTaggingTool (30892)
- ShapeTools (1000)
- buildings_tools (30892)
- download_along (30892)
- reltoolbox (30892)
- reverter (30892)
- terracer (30892)
- turnlanes (30892)
- turnrestrictions (30892)
- utilsplugin2 (30892)
- wikipedia (30892)

Last errors/warnings:
- W: Could not get presets icon 
- E: Failed to locate image ''
- W: Could not get presets icon 
- E: Failed to locate image 'presets/soccer.png'
- W: Could not get presets icon presets/soccer.png

Attachments (1)

18-01-2015 16-27-14.png (310.5 KB) - added by Gilbert54 4 years ago.
screenshot

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by Gilbert54

Attachment: 18-01-2015 16-27-14.png added

screenshot

comment:1 Changed 4 years ago by Don-vip

Component: Core validatorInternal preset
Description: modified (diff)
Keywords: route foot hiking added
Summary: Validator complains that relation type = route / route = foot is an un known route typeAdd relation type = route / route = foot to default preset
Type: defectenhancement

comment:2 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 4 years ago by skyper

Think foot is way to general. Compared with hiking walking would be the value to use.

comment:4 in reply to:  3 ; Changed 4 years ago by anonymous

Replying to skyper:

Think foot is way to general. Compared with hiking walking would be the value to use.

I didn't intend to start a debate about "foot" vs. "walking", although I agree than "walking" is probably the more appropriate term for what in this particular instance is really "a walk in the park" and through the city. I really like the suggestion.
When I look for the most common values on Taginfo I find 25,000 times "foot" and about 500 times "walking"...
But that's something which should be discussed on the related wiki's "http://wiki.openstreetmap.org/wiki/Tag:route%3Dfoot" and/or "http://wiki.openstreetmap.org/wiki/Relation:route" where "walking" isn't on the menu and "foot" seems to be the city version of "hiking". Just tagging along with the recommendations ;-)
My main concern was that the validator seemed to have an issue with the relation type being "route" - at least that's how I read the message. Maybe the error message is misleading and really meant "route = foot" to be the unknown type ? In that case, the error message may need a bit of polishing.

Cheers, Gilbert

comment:5 Changed 4 years ago by Don-vip

Ticket #11186 has been marked as a duplicate of this ticket.

comment:6 Changed 4 years ago by Klumbumbus

Cc: Klumbumbus added

comment:7 in reply to:  4 Changed 4 years ago by skyper

Replying to anonymous:

When I look for the most common values on Taginfo I find 25,000 times "foot" and about 500 times "walking"...

More than 21,000 of the 25,000 are tagged with network=rwn or network=lwn.

comment:8 Changed 3 years ago by Klumbumbus

Ticket #12552 has been marked as a duplicate of this ticket.

comment:9 Changed 3 years ago by Klumbumbus

Cc: wernerschka added; Klumbumbus removed

comment:10 Changed 3 years ago by wernerschka

Since my Ticket #12552 was marked as a duplicate, I wanna ask here again, since this detail wasn't mentioned before:

Regarding to ​http://wiki.openstreetmap.org/wiki/Hiking#Tagging_walking_and_hiking_Route_Networks
route=foot is at least not depreciated and sometimes used for "easy, short" hiking routes (Walking).
So as long as these value as an alternative to route=hiking is not depreciated by the OSM community, JOSM should not create a warning.

The Wiki doesn't propose that a route containing a network tag (lwn, rwn, nwn, iwn) must not have route=foot
There are some easy, short "walking" routes with OSM, being part of a lwn and tagged with route=foot

Last edited 3 years ago by wernerschka (previous) (diff)

comment:11 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 9852/josm:

fix #10991 - add preset for route=foot

comment:12 Changed 3 years ago by Klumbumbus

Milestone: 16.02

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.