Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#10970 closed enhancement (fixed)

link to mapillary object

Reported by: Polyglot Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin tag2link Version:
Keywords: mapillary Cc:

Description

I just discovered Mapillary. I'd like to link back to pictures I've taken from 'noteworthy' objects during my surveys. Do you think it would be possible to somehow support the following in JOSM?

mapillary=z0PmxYaUUDIzLYZSVLncsQ

with a button to open the following link directly in a browser?

http://www.mapillary.com/map/im/z0PmxYaUUDIzLYZSVLncsQ ?

Alternatively, as I already know you are likely to say that tag doesn't even exist (yet). Would it be possible to open a browser window directly at the lat/lon location in the center of the selected objects? It would enable finding out whether pictures are available for that location in a convenient way. Not sure how to add lat/lon to the url though.

Jo

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by bastiK

Component: CorePlugin tag2link
Owner: changed from team to Don-vip
Summary: mapillarylink to mapillary object

There is a plugin called tag2link, where this would fit in.

For plugins, the support for bleeding edge stuff is much more acceptable, so I would say it is okay.

One comment on the new tag: if it is used to link to the source of information, then source=mapillary:z0PmxYaUUDIzLYZSVLncsQ would be a better choice.

comment:2 Changed 5 years ago by Don-vip

Keywords: mapillary added

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o31066:31067].

comment:4 Changed 4 years ago by Don-vip

Ticket #11536 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.