Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10947 closed defect (fixed)

"No data found in this area." message when Overpass query times out

Reported by: bastiK Owned by: team
Priority: normal Milestone: 15.09
Component: Core Version:
Keywords: mirrored_download Cc:

Description

When making the following request in "Download from Overpass API":

[timeout:30];
is_in(50.73322,7.09828);
relation(pivot);
(._;>;);
out meta;

I get a popup message "No data found in this area."

However, I see that the request timed out (wireshark):

<?xml version="1.0" encoding="UTF-8"?>
<osm version="0.6" generator="Overpass API">
<note>The data included in this document is from www.openstreetmap.org. The data is made available under ODbL.</note>
<meta osm_base="2015-01-07T23:38:02Z" areas="2015-01-07T10:31:02Z"/>

  <bounds minlat="38.9013" minlon="-17.8052" maxlat="61.7253" maxlon="38.1959"/>

<remark> runtime error: Query timed out in "query" at line 3 after 31 seconds. </remark>

</osm>

I would prefer if this message was parsed and displayed in a message window or at least on the command line.

JOSM: 7935
mirored download: 30892

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by bastiK

In Overpass turbo, this request finishes within a minute:

/api/interpreter?data=is_in%2850.73322%2C7.09828%29%3B%0Arelation%28pivot%29%3B%0A%28._%3B%3E%3B%29%3B%0Aout%20meta%3B

This is what JOSM sends (increasing the timeout to 130 seconds still fails):

http://overpass-api.de/api/interpreter?data=%5Bbbox%5D%5Btimeout%3A130%5D%3B%0Ais_in%2850.73322%2C7.09828%29%3B%0Arelation%28pivot%29%3B%0A%28._%3B%3E%3B%29%3B%0Aout+meta%3B&bbox=-19.0442031,38.2664307,39.4348281,62.1076115

How can I get rid of the bbox stuff (in case it causes the problems)?

Last edited 5 years ago by bastiK (previous) (diff)

comment:2 Changed 5 years ago by anonymous

Bascially by passing the query to the standard "File > Open location ..." dialogue. The bbox comes from the bbox selector and can currently not be turned off.

comment:3 Changed 4 years ago by simon04

Component: Plugin mirrored_downloadCore
Keywords: mirrored_download added
Owner: changed from roland.olbricht to team

mirrored_download is now part of core (see #11428)

comment:4 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 8788/josm:

fix #10947 - "No data found in this area." message when Overpass query times out

Detect "runtime error" in the <remark> element of the returned XML.

comment:5 Changed 4 years ago by simon04

Milestone: 15.09

comment:6 Changed 4 years ago by simon04

Ticket #8841 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.