Modify

Opened 9 years ago

Closed 9 years ago

#10942 closed defect (duplicate)

DataIntegrityProblemException while splitting a way

Reported by: naoliv Owned by: naoliv
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

I pressed P to split a way and got this:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-01-06 02:35:14
Last Changed Author: Klumbumbus
Revision: 7929
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-01-06 01:56:26 +0100 (Tue, 06 Jan 2015)
Last Changed Rev: 7929

Identification: JOSM/1.5 (7929 pt_BR) Linux Debian GNU/Linux 8.0 (jessie)
Memory Usage: 4541 MB / 8158 MB (1707 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u71-2.5.3-2
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Dataset consistency test:
[DELETED REFERENCED] {Relation id=4141954 version=1 MVT [caminho 138182296, caminho 243112094, caminho 243112092, caminho -1605152, caminho -1605279, caminho -1605227]} refers to deleted primitive {Way id=-1605227 version=0 MVDT nodes=[]}
[DELETED REFERENCED] {Relation id=4141959 version=1 MVT [caminho -1605322, caminho 138182292, caminho -1605227, caminho 138182296, caminho 243112094, caminho 243112092, caminho -1627162, caminho -1627161, caminho -1605319]} refers to deleted primitive {Way id=-1605227 version=0 MVDT nodes=[]}


Plugins:
- Create_grid_of_ways (30892)
- ImageryCache (30892)
- OpeningHoursEditor (30892)
- PicLayer (30892)
- SimplifyArea (30892)
- buildings_tools (30892)
- conflation (0.1.7)
- contourmerge (1012)
- download_along (30892)
- editgpx (30892)
- geotools (30892)
- importvec (30892)
- jts (30892)
- log4j (30892)
- measurement (30892)
- merge-overlap (30892)
- opendata (30892)
- pbf (30892)
- pdfimport (30892)
- poly (30892)
- reverter (30892)
- scripting (30702)
- todo (29154)
- turnrestrictions (30892)
- undelete (30892)
- utilsplugin2 (30892)

Last errors/warnings:
- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Boundaries@40457344, code=601, message=Cruzamento de fronteiras]
- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Boundaries@40457344, code=601, message=Cruzamento de fronteiras]
- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Boundaries@40457344, code=601, message=Cruzamento de fronteiras]
- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Boundaries@40457344, code=601, message=Cruzamento de fronteiras]
- E: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=4141959 version=1 MVT [caminho -1605322, caminho 138182292, caminho -1605227, caminho 138182296, caminho 243112094, caminho 243112092, caminho -1627162, caminho -1627161, caminho -1605319]}


ERRO: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=4141959 version=1 MVT [caminho -1605322, caminho 138182292, caminho -1605227, caminho 138182296, caminho 243112094, caminho 243112092, caminho -1627162, caminho -1627161, caminho -1605319]}
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=4141959 version=1 MVT [caminho -1605322, caminho 138182292, caminho -1605227, caminho 138182296, caminho 243112094, caminho 243112092, caminho -1627162, caminho -1627161, caminho -1605319]}
	at org.openstreetmap.josm.data.osm.Relation.checkMembers(Relation.java:494)
	at org.openstreetmap.josm.data.osm.Relation.fireMembersChanged(Relation.java:501)
	at org.openstreetmap.josm.data.osm.Relation.setMembers(Relation.java:63)
	at org.openstreetmap.josm.data.osm.Relation.cloneFrom(Relation.java:233)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:65)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:53)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:43)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:69)
	at org.openstreetmap.josm.actions.SplitWayAction.actionPerformed(SplitWayAction.java:185)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1662)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2869)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2961)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2953)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2832)
	at java.awt.Component.processEvent(Component.java:6293)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1887)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:762)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1027)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:899)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:727)
	at java.awt.Component.dispatchEventImpl(Component.java:4742)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (3)

comment:1 by Don-vip, 9 years ago

Owner: changed from team to naoliv
Status: newneedinfo

can you please attach a dataset causing the validator warnings listed in the status report, and tell us the actions you made to have these warnings? It should allow us to reproduce the problem:

- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Boundaries@40457344, code=601, message=Cruzamento de fronteiras]

comment:2 by naoliv, 9 years ago

Monster file, as always: http://naoliv.iq.unesp.br/osm/10942.osm.bz2
I need to find the object that gave this error, however.

comment:3 by skyper, 9 years ago

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #7621.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain naoliv.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.