Modify

Opened 7 years ago

Closed 4 years ago

#10901 closed enhancement (duplicate)

Adjust imagery offset dialog default position nuisance

Reported by: pinkduck Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: tested
Keywords: adjust imagery, dialog, position Cc:

Description

What steps will reproduce the problem?

  1. Imagery > Imagery offset > Bing sat
  2. Dialog appears in centre of background view
  3. User has to drag it away every time as typically the central thing is what needs to be aligned with.

What is the expected result?

The dialog appears somewhere off-centre by default, or appears where the user last positioned it.

What happens instead?

The dialog appears in the centre, necessitating a drag out of the way each time alignment changes in an editing session.

Please provide any additional information below. Attach a screenshot if possible.

Revision: 7777
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-12-09 18:14:49 +0100 (Tue, 09 Dec 2014)
Build-Date: 2014-12-09 17:17:36
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7777

Identification: JOSM/1.5 (7777 en_GB) Windows 7 64-Bit
Memory Usage: 249 MB / 455 MB (45 MB allocated, but free)
Java version: 1.8.0_25, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-XX:HeapDumpPath=C:\Users\Pink Duck\Downloads\JOSM.hprof]
Dataset consistency test: No problems found

Plugins:
- reverter (30737)
- terracer (30737)
- utilsplugin2 (30762)

Last errors/warnings:
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by skyper

Maybe in addition to remembering position and size it could be an toggle dialog and stickable to the right side.

comment:2 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15493.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.