Modify

Opened 5 years ago

Closed 5 years ago

#10850 closed defect (fixed)

Remaining boundingbox in imagery preferences outline preview after adding a new shape and updating the imagery preferences

Reported by: mdk Owned by: team
Priority: minor Milestone: 14.12
Component: Core imagery Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open Imagery Preferences
  2. Select an imagery provider which has <bounds> without <shape> (see http://josm.openstreetmap.de/wiki/Maps and sub-pages for different countries) -> you see the bounding box in the preview map of the preference dialog
  3. Edit the wiki-page and replace the <bounds> element with a new (and valid) which contains a <shape>.
  4. Refresh the imagery preferences ("reload defaults" button right of the preview map)

What is the expected result?

After reloading (or at least after re-selecting the chosen imagery provider the preview should change from the old boundary box to the new shape.

What happens instead?

The old bounding box is nw shown always, until you close and re-openthe preference windows. If you select any other imagery provider, the outline for this provider (shape, bounding box or nothing) is shown PLUS the old bounding box from the changed imagery provider.

The list of shapes shown in the preview map must be cleared after reload. And it would be nice, if the preview is refreshed after "reload defaults".

Please provide any additional information below. Attach a screenshot if possible.

You can easily create a shape with the imagery-xml-bounds plugin (http://wiki.openstreetmap.org/wiki/JOSM/Plugins/Imagery-XML-Bounds):

  • open new (empty) layer
  • show the imagery layer
  • trace the outline of the imagery
  • select the outline and call "XML imagery bounds" from the context menu of the selection view
  • copy <bounds> element with <shape> child element
  • add or replace <bounds> element in the http://josm.openstreetmap.de/wiki/Maps wiki-page
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-12-11 02:33:43
Last Changed Author: Don-vip
Revision: 7787
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-12-11 00:15:17 +0100 (Thu, 11 Dec 2014)
Last Changed Rev: 7787

Identification: JOSM/1.5 (7787 en) Linux Ubuntu 14.04.1 LTS
Memory Usage: 360 MB / 876 MB (205 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u71-2.5.3-0ubuntu0.14.04.1
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/michael/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ColumbusCSV (30762)
- FastDraw (30762)
- HouseNumberTaggingTool (30762)
- OpeningHoursEditor (30737)
- RoadSigns (30788)
- SimplifyArea (30791)
- buildings_tools (30762)
- contourmerge (1012)
- imagery-xml-bounds (30735)
- imagery_offset_db (30808)
- poly (30738)
- public_transport (30762)
- reltoolbox (30841)
- reverter (30737)
- scoutsigns (8)
- terracer (30737)
- turnrestrictions (30762)
- utilsplugin2 (30762)

Last errors/warnings:
- E: Failed to locate image 'maxspeed_icon.svg'
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

Attachments (1)

bounds.xml (858 bytes) - added by mdk 5 years ago.
valid bounds for "SIGIP - Orthophoto 2012" from CH

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by mdk

Attachment: bounds.xml added

valid bounds for "SIGIP - Orthophoto 2012" from CH

comment:1 Changed 5 years ago by mdk

I add (see attachment) a valid <bounds> element for the Swiss (CH) "SIGIP - Orthophoto 2012" imagery provider.

You can finally add this shape, because it is actual missing and it is valid for this provider!

Last edited 5 years ago by mdk (previous) (diff)

comment:2 Changed 5 years ago by mdk

Perhaps I can point directly to the problem: I saw, that you can make multi-selection of imagery providers. Each time you add a provider to the selection, the outline (bounding box or shape) is added. Each time a provider is deselected, the outline is removed from the collection to be drawn in the preview map.

But it looks like on "reload defaults" the selection is cleared without removing the outlines from the previous selected providers.

So either ANY change of the selection-List must also change the list of outlines to be shown, or don't have two independent collections (selected providers and outlines to display) and create the list of outlines each time the selection changes directly from the list of selected imagery providers.

comment:3 Changed 5 years ago by Don-vip

Milestone: 14.12

comment:4 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7860/josm:

fix #10850 - clear imagery providers map preview when reloading default list

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.