Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10795 closed defect (fixed)

restart does not work with jnlp

Reported by: Klumbumbus Owned by: team
Priority: normal Milestone: 14.11
Component: Core restart Version: latest
Keywords: template_report webstart jnlp Cc:

Description

What steps will reproduce the problem?

  1. start with jnlp
  2. use restart function

What is the expected result?

What happens instead?

I get the following error and the restart fails:

InvalidArgumentException[ Ungültige Argumente angegeben: { }]
	at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
	at com.sun.javaws.Main.access$000(Unknown Source)
	at com.sun.javaws.Main$1.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Please provide any additional information below. Attach a screenshot if possible.

This is not a new error for me. This happens already since a long time.
I also deleted Java cache as described in #9917.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-11-30 20:09:35
Last Changed Author: Don-vip
Revision: 7754
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-11-30 21:06:38 +0100 (Sun, 30 Nov 2014)
Last Changed Rev: 7754

Identification: JOSM/1.5 (7754 en) Windows 7 32-Bit
Memory Usage: 110 MB / 247 MB (44 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre7\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Users\Stefan\Desktop\josm-latest.jnlp, -Djnlpx.remove=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=49381, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]

Plugins:
- DirectUpload (30737)
- HouseNumberTaggingTool (30762)
- OpeningHoursEditor (30737)
- PicLayer (30762)
- Tracer2 (30695)
- buildings_tools (30762)
- download_along (30762)
- editgpx (30737)
- imagery_offset_db (30808)
- measurement (30737)
- mirrored_download (30762)
- notes (v0.9.5)
- public_transport (30762)
- reltoolbox (30762)
- reverter (30737)
- tag2link (30719)
- terracer (30737)
- turnrestrictions (30762)
- undelete (30762)
- utilsplugin2 (30762)
- wikipedia (30780)

Last errors/warnings:
- E: Failed to locate image 'josm_small.png'
- W: Mappaint style "standard" (JOSM default (XML; old version)) icon "josm_small.png" not found.
- E: Failed to locate image 'error_small.png'
- W: Mappaint style "standard" (FIXME Highlight Warnings) icon "error_small.png" not found.

Attachments (0)

Change History (12)

comment:1 Changed 6 years ago by Don-vip

Component: CoreCore restart
Owner: changed from team to Klumbumbus
Status: newneedinfo

It works for me, I need more info:

  • do you have several versions of Java installed?
  • when you tried to delete Java cache, did you tick the last checkbox? ("Installed Applications and Applets")

comment:2 in reply to:  1 Changed 6 years ago by Klumbumbus

Replying to Don-vip:

It works for me, I need more info:

  • do you have several versions of Java installed?

no only Java 7

  • when you tried to delete Java cache, did you tick the last checkbox? ("Installed Applications and Applets")

yes

comment:3 Changed 6 years ago by Klumbumbus

This bug report was created with a fresh downloaded jnlp from the josm website. When I use my modified jnlp (with <argument>--debug</argument>) the error message changes to:

InvalidArgumentException[ Ungültige Argumente angegeben: {--debug }]
	at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
	at com.sun.javaws.Main.access$000(Unknown Source)
	at com.sun.javaws.Main$1.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

comment:4 Changed 6 years ago by Klumbumbus

After deleting the cache, a new shortcut was created on my desktop, which links to C:\Windows\System32\javaws.exe -localfile -J-Djnlp.application.href=https://josm.openstreetmap.de/download/josm-latest.jnlp "C:\Users\Stefan\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\31\583aa85f-56919498"

When I start josm by clicking on this shortcut, the restart works, but if I start josm by clicking on the jnlp, restart does not work.

comment:5 in reply to:  4 Changed 6 years ago by Don-vip

Keywords: jnlp added
Owner: changed from Klumbumbus to team
Status: needinfonew

Replying to Klumbumbus:

if I start josm by clicking on the jnlp

Didn't try this way, always with the desktop shortcut. Indeed I reproduce the error when launching the .jnlp file.

comment:6 Changed 6 years ago by Klumbumbus

I need to always start with the jnlp because I want auto update and higher RAM size (I added <j2se version="1.7+" initial-heap-size="256m" max-heap-size="768m"/> to the jnlp).

comment:7 Changed 6 years ago by Don-vip

Milestone: 14.11

comment:8 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7755/josm:

fix #10795 - restart does not work with jnlp if process is launched by jp2launcher.exe

comment:9 Changed 6 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

Still the same error for me with 7755. (I deleted the cache again before the test.)

comment:10 Changed 6 years ago by Don-vip

In 7756/josm:

see #10795 - get debug info

comment:11 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 7757/josm:

fix #10795 - restart does not work with jnlp if process is launched by jp2launcher.exe

comment:12 Changed 6 years ago by Don-vip

In 7758/josm:

see #10795 - avoid error caused by a missing jnlp file on the second restart

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.