Modify

Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#10789 closed enhancement (fixed)

Support changeset discussions (comments) in history dialog

Reported by: Don-vip Owned by: team
Priority: normal Milestone: 16.02
Component: Core Version:
Keywords: api changeset comment discussion history ObjectHistory Cc: skyper, openstreetmap.org-user-d1g

Description (last modified by openstreetmap.org-user-d1g)

Continuation of #10701:

It could be useful to find a way of displaying changesets comments in history dialog.

UI Proposals are welcome.

Attachments (2)

2015-04-23-211425_1198x948_scrot.png (57.4 KB) - added by simon04 4 years ago.
We do have a display of changeset comments …
2016-01-18-193337_848x481_scrot.png (16.7 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 5 years ago by Klumbumbus

Copy of 10701#comment:9:

I suggest to display a link in the history dialog "Display discussion to this changeset" if there is at least one discussion comment. And the link opens the changeset manager dialog and displays directly the discussion.

comment:2 Changed 5 years ago by skyper

Cc: skyper added

comment:3 Changed 5 years ago by Don-vip

Milestone: 14.1215.01

comment:4 Changed 5 years ago by Don-vip

Ticket #11009 has been marked as a duplicate of this ticket.

comment:5 Changed 5 years ago by Don-vip

Milestone: 15.0115.02

move tickets that have not been treated this month to next milestone

comment:6 Changed 5 years ago by Don-vip

Milestone: 15.02

Changed 4 years ago by simon04

We do have a display of changeset comments …

comment:7 Changed 4 years ago by Klumbumbus

your screenshot shows the changeset dialog. this ticket is about the history dialog (strg+h)

comment:8 Changed 4 years ago by simon04

In 8254/josm:

see #10789 - History dialog: add button to open changeset dialog

comment:9 Changed 4 years ago by Klumbumbus

It would also be nice if in the hstory browser there is for example this icon source:/trunk/images/dialogs/notes/note_comment.png next to the changeset id, if there are comments to this changeset.

Last edited 4 years ago by Klumbumbus (previous) (diff)

comment:10 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 9526/josm:

fix #10789 - History dialog: indicate the number of changeset comments

Clicking on the button opens the changeset manager and displays the comments

comment:11 Changed 4 years ago by simon04

Milestone: 16.02


Changed 4 years ago by simon04

comment:12 Changed 4 years ago by bastiK

nice :)

comment:13 Changed 4 years ago by Don-vip

great! I couldn't think of a simple non-intrusive UI, this is good work :)

comment:14 in reply to:  11 Changed 3 years ago by openstreetmap.org-user-d1g

Replying to simon04:

2016-01-18-193337_848x481_scrot.png

Why we don't have it always :( It should show "0" messages if there no discussion.

It is easy to find discussion if it was in the latest version.

But in order to find discussion you have to compare each pair of changes. This might be complicated with relations/highways where they have 100 of versions, but only few discussion and often get 10 versions quickly after discussion. You will check 10 latest and would never know when to stop or if it makes sense to check them.

I would use colour coding of the left part (with 5 columns): it should highlight versions with discussions.

Last edited 3 years ago by openstreetmap.org-user-d1g (previous) (diff)

comment:15 Changed 3 years ago by openstreetmap.org-user-d1g

Cc: openstreetmap.org-user-d1g added
Description: modified (diff)
Keywords: ObjectHistory added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.