Modify

Opened 5 years ago

Closed 5 years ago

#10652 closed defect (fixed)

GeoTools plugin, descriptor already registered against the name "ImageRead" under registry mode "rendered"

Reported by: joe@… Owned by: Don-vip
Priority: minor Milestone:
Component: Plugin geotools Version: latest
Keywords: Cc:

Description

What steps will reproduce the problem?

  1. Install the opendata plugin, which requires jts;geotools;utilsplugin2
  2. Restart JOSM
  3. geotools plugin cannot load, select 'Keep' or 'Disable'

What is the expected result?

JOSM to load normally with the plugin enabled.

What happens instead?

I must choose to Disable the plugin or Keep it non-functioning.

Please provide any additional information below. Attach a screenshot if possible.

I am able to run JOSM with this plugin on another machine on Mac OS X 10.10. The machine which this error occurs is used for a lot of geospatial development and mapping - so perhaps something else installed on my system/in the environment is causing this conflict...but I am at a loss as to what it could be.

Revision: 7588
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-09-29 23:52:43 +0200 (Mon, 29 Sep 2014)
Build-Date: 2014-09-29 22:12:08
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7588

Identification: JOSM/1.5 (7588 en) Mac OS X 10.10
Memory Usage: 104 MB / 114 MB (58 MB allocated, but free)
Java version: 1.8.0_25, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1YbXgxMjhtAA==, -Djnlpx.jvm=<java.home>/bin/java, -Djnlpx.splashport=-1, -Djnlpx.home=/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=/var/folders/f4/nblms9cj4sq5jrwwv_v56kch0000gn/T/session7264534427278414828, -Djnlpx.heapsize=NULL,NULL, -Djava.security.policy=file:/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/lib/security/javaws.policy, -DtrustProxy=true, -Dsun.awt.warmup=true, -Djava.security.manager]

Plugins:
- geotools
- jts (30416)
- opendata (30607)
- utilsplugin2 (30460)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin geotools. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.IllegalArgumentException: A descriptor is already registered against the name "ImageRead" under registry mode "rendered"

Attachments (0)

Change History (3)

comment:1 in reply to:  description Changed 5 years ago by Don-vip

Component: CorePlugin geotools
Keywords: geotools plugin removed
Owner: changed from team to Don-vip

Replying to joe@…:

I am able to run JOSM with this plugin on another machine on Mac OS X 10.10. The machine which this error occurs is used for a lot of geospatial development and mapping - so perhaps something else installed on my system/in the environment is causing this conflict.

Well, you're probably the only one that can understand and fix the problem, then.

comment:2 Changed 5 years ago by joe@…

Well, you're probably the only one that can understand and fix the problem, then.

...but I am at a loss as to what it could be.

This is some more detailed information from the Terminal output, when starting JOSM built from source:

INFO: loading plugin 'jts' (version 30416)
INFO: loading plugin 'geotools' (version 30569)
ERROR: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin geotools. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.IllegalArgumentException: A descriptor is already registered against the name "ImageRead" under registry mode "rendered"
org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin geotools
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:319)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:563)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:625)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:665)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:413)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:316)
	... 4 more
Caused by: java.lang.IllegalArgumentException: A descriptor is already registered against the name "ImageRead" under registry mode "rendered"
	at javax.media.jai.DescriptorCache.addDescriptor(DescriptorCache.java:165)
	at javax.media.jai.OperationRegistry.registerDescriptor(OperationRegistry.java:707)
	at javax.media.jai.ThreadSafeOperationRegistry.registerDescriptor(ThreadSafeOperationRegistry.java:156)
	at com.sun.media.jai.imageioimpl.ImageReadWriteSpi.updateRegistry(ImageReadWriteSpi.java:86)
	at org.openstreetmap.josm.plugins.geotools.GeoToolsPlugin.initJAI(GeoToolsPlugin.java:41)
	at org.openstreetmap.josm.plugins.geotools.GeoToolsPlugin.<init>(GeoToolsPlugin.java:22)
	... 9 more
INFO: loading plugin 'utilsplugin2' (version 30460)
INFO: loading plugin 'opendata' (version 30607)
INFO: Enabled EDT checker, wrongful access to gui from non EDT thread will be printed to console
Last edited 5 years ago by Don-vip (previous) (diff)

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Should be fixed in [o30755:30756].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.