Modify

Opened 7 years ago

Closed 6 years ago

#10648 closed enhancement (fixed)

Mapillary plugin

Reported by: hjart Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: Mapillary gsoc Cc: lists@…, holgermappt

Description (last modified by hjart)

Hi

The guys over at Mapillary.com recently has created an enhancement to iD which lets mappers traverse their image sequences from within iD. As an experienced and dedicated JOSM user though I would much prefer being able to do this from within JOSM. I love Mapillary and at this point has about a dozen sequences totalling ~1000 images in there and regularly check other sequences/images for useful info, so I would very much appreciate if anyone finds some time to create a useful Mapillary plugin for JOSM.

Apparently the Mapillary guys currently doesn't have the extra resources for this (see the end of https://github.com/mapillary/mapillary_issues/issues/148), which is why I'm asking here.

Mapillary has some documentation for their API at http://www.mapillary.com/developer.html (snipped from Ticket #10919)

Thank you

Attachments (0)

Change History (20)

comment:1 Changed 7 years ago by hjart

Description: modified (diff)

comment:2 Changed 7 years ago by jaakkoh

Not that I could contribute any code to this but just wanted to chime in that a JOSM plugin would be absolutely fantastic.

I've been doing a stack of photo mapping over time and used OSMTracker until Mapillary arrived this spring and would just want to note that what exists already with showing the photos in JOSM (locally, though) is pretty much what I'd love to see with Mapillary photos too.

Also, as a related note, I can already view Mapillary photos locally by simply dragging and dropping (local) photos to JOSM. This produces a very nice experience for the part of the photos that are dropped in as JOSM shows even a nice directional "beak" (that's what it looks like more than an arrow) to the direction of what is the compass reading in the photo.
I'm not sure where the functionality that I currently see in JOSM comes from as I have a few photo related plugins activated -- but it's great.

If there only was a way to pull information dynamically from Mapillary's API into JOSM and see all the photos that everyone has uploaded for a given area. That would be just great. I'd by a case of beers to anyone who'd do that. And/or would happily chip in at least $20 to a Kickstarter/what_not crowdfunding project for this.

comment:3 Changed 7 years ago by richlv

couldn't find a way to watch/subscribe, leaving this comment in hope to get notifications

comment:4 Changed 7 years ago by hjart

Description: modified (diff)

comment:5 Changed 7 years ago by Aun Johnsen <lists@…>

Cc: lists@… added

comment:6 Changed 7 years ago by Don-vip

Ticket #10919 has been marked as a duplicate of this ticket.

comment:7 Changed 7 years ago by hjart

Description: modified (diff)

comment:8 Changed 7 years ago by AndrewSnow

Wanted to add my desire to see this happen. I've contributed 30K images to Mapillary and made 650K changes to OSM, mostly in JOSM. Having direct access to Mapillary images synced to the area I'm working on in JOSM will speed up the editing and vastly improve the level of detail in the map.

comment:9 Changed 7 years ago by abienvenu

In addition, Mapillary in JOSM would make mapping activities more enjoyable!

comment:10 Changed 7 years ago by Polyglot

I think I'd like to attempt it. The first question that comes to mind is: build further on the photo mapping plug in or fork it creating a new plugin?

Jo

comment:11 Changed 7 years ago by Aun Johnsen <lists@…>

Looking forward to it, without looking at it I would guess building out the photo mapping plug in would be most reasonable, you probably have most of what you need in that plugin. Making a new plugin probably would result in a lot of double code.

comment:12 Changed 7 years ago by holgermappt

Cc: holgermappt added

I also thought about this. One option would be to use most of the infrastructure of the current photo layer (GeoImageLayer, JOSM core functionality) including image display. It would need to learn to load photos from an URL and to cache them locally (which would be cool anyway). The plugin then talks to the Mapillary API and adds the URLs to the photo layer. But on the other hand a more dynamic layer like the notes layer might be better for a constant update of the available photos. It's not just photos, there are also the tracks.

Edit: I think it definitely should be a new plugin. With the traffic signs, the possible option to display them and to give feedback about falsely recognized signs, and possibly other details and options (image upload?) this will not have that much in common with the current geo image layer. Which doesn't mean that both can not share common code.

I can volunteer to do some smaller tasks or review the plugin. But I don't have enough time to write or co-author it.

Last edited 7 years ago by holgermappt (previous) (diff)

comment:13 Changed 7 years ago by gyllen

Polyglot, gyllen from Mapillary here. Shoot me an email at gyllen at mappilary dot com and I will give you access to new API.

comment:14 Changed 7 years ago by peter@…

Guys,
we are happy to help from the Mapillary side, as mentioned above we currently have no bandwidth for the job itself - help is greatly appreciated. Contact me at @peterneubauer if you need anything.

comment:15 in reply to:  13 Changed 7 years ago by anonymous

Replying to gyllen:

Polyglot, gyllen from Mapillary here. Shoot me an email at gyllen at mappilary dot com and I will give you access to new API.

Address is gyllen at mapillary dot com

comment:16 Changed 7 years ago by AlexandreMBM

Already is there code being versioned?

comment:17 Changed 7 years ago by Don-vip

Keywords: gsoc added

comment:18 Changed 6 years ago by Don-vip

Component: PluginPlugin mapillary
Owner: changed from team to nokutu

comment:19 Changed 6 years ago by malenki

Since there is now a Mapillary plugin shouldn't this ticket be solved?

comment:20 Changed 6 years ago by stoecker

Resolution: fixed
Status: newclosed

As we already see more detailed bug reports (which are fixed fast as I must say!) I think: Yes.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.