Modify

Opened 7 years ago

Closed 7 years ago

#10645 closed defect (duplicate)

Strange Nominatim Output causes Exception

Reported by: Nakaner Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Hi,

Nominatim is not working at the moment. If I use the Nominatim search field to download data from API, I get following exception:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-29 22:12:08
Last Changed Author: Don-vip
Revision: 7588
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-29 23:52:43 +0200 (Mon, 29 Sep 2014)
Last Changed Rev: 7588

Identification: JOSM/1.5 (7588 de) Linux Arch Linux
Memory Usage: 334 MB / 1746 MB (93 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true]
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30609)
- PicLayer (30436)
- buildings_tools (30485)
- notes (v0.9.4)
- proj4j (30483)
- reverter (30521)
- terracer (30643)
- utilsplugin2 (30460)

Last errors/warnings:
- E: org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content ist nicht zulässig in Prolog.. Ursache: org.xml.sax.SAXParseException: Content ist nicht zulässig in Prolog.
- E: org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content ist nicht zulässig in Prolog.. Ursache: org.xml.sax.SAXParseException: Content ist nicht zulässig in Prolog.
- E: org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content ist nicht zulässig in Prolog.. Ursache: org.xml.sax.SAXParseException: Content ist nicht zulässig in Prolog.
- E: org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content ist nicht zulässig in Prolog.. Ursache: org.xml.sax.SAXParseException: Content ist nicht zulässig in Prolog.
- E: org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content ist nicht zulässig in Prolog.. Ursache: org.xml.sax.SAXParseException: Content ist nicht zulässig in Prolog.

org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content ist nicht zulässig in Prolog.
	at org.openstreetmap.josm.gui.download.PlaceSelection$NameQueryTask.realRun(PlaceSelection.java:385)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:150)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content ist nicht zulässig in Prolog.
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:198)
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:177)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:441)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:368)
	at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1436)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:999)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:606)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:848)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:777)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:648)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(SAXParserImpl.java:332)
	at org.openstreetmap.josm.gui.download.PlaceSelection$NameQueryTask.realRun(PlaceSelection.java:378)
	... 7 more

If I visit [nominatim.openstreetmap.org] via Firefox, I get:

string(19) "pgsql://@/nominatim" object(DB_Error)#2 (8) { ["error_message_prefix"]=> string(0) "" ["mode"]=> int(1) ["level"]=> int(1024) ["code"]=> int(-24) ["message"]=> string(24) "DB Error: connect failed" ["userinfo"]=> string(272) " [nativecode=pg_connect(): Unable to connect to PostgreSQL server: could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?] ** pgsql://@/nominatim" ["backtrace"]=> array(7) { [0]=> array(6) { ["file"]=> string(21) "/usr/share/php/DB.php" ["line"]=> int(966) ["function"]=> string(10) "PEAR_Error" ["class"]=> string(10) "PEAR_Error" ["type"]=> string(2) "->" ["args"]=> array(5) { [0]=> string(24) "DB Error: connect failed" [1]=> int(-24) [2]=> int(1) [3]=> int(1024) [4]=> string(249) " [nativecode=pg_connect(): Unable to connect to PostgreSQL server: could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?]" } } [1]=> array(7) { ["file"]=> string(23) "/usr/share/php/PEAR.php" ["line"]=> int(531) ["function"]=> string(8) "DB_Error" ["class"]=> string(8) "DB_Error" ["object"]=> *RECURSION* ["type"]=> string(2) "->" ["args"]=> array(4) { [0]=> int(-24) [1]=> int(1) [2]=> int(1024) [3]=> string(249) " [nativecode=pg_connect(): Unable to connect to PostgreSQL server: could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?]" } } [2]=> array(7) { ["file"]=> string(28) "/usr/share/php/DB/common.php" ["line"]=> int(1908) ["function"]=> string(10) "raiseError" ["class"]=> string(4) "PEAR" ["object"]=> object(DB_pgsql)#1 (28) { ["phptype"]=> string(5) "pgsql" ["dbsyntax"]=> string(5) "pgsql" ["features"]=> array(7) { ["limit"]=> string(5) "alter" ["new_link"]=> string(5) "4.3.0" ["numrows"]=> bool(true) ["pconnect"]=> bool(true) ["prepare"]=> bool(false) ["ssl"]=> bool(true) ["transactions"]=> bool(true) } ["errorcode_map"]=> array(0) { } ["connection"]=> bool(false) ["dsn"]=> array(9) { ["phptype"]=> string(5) "pgsql" ["dbsyntax"]=> string(5) "pgsql" ["username"]=> string(0) "" ["password"]=> bool(false) ["protocol"]=> string(3) "tcp" ["hostspec"]=> string(0) "" ["port"]=> bool(false) ["socket"]=> bool(false) ["database"]=> string(9) "nominatim" } ["autocommit"]=> bool(true) ["transaction_opcount"]=> int(0) ["affected"]=> int(0) ["row"]=> array(0) { } ["_num_rows"]=> array(0) { } ["fetchmode"]=> int(1) ["fetchmode_object_class"]=> string(8) "stdClass" ["was_connected"]=> NULL ["last_query"]=> string(0) "" ["options"]=> array(8) { ["result_buffering"]=> int(500) ["persistent"]=> bool(false) ["ssl"]=> bool(false) ["debug"]=> int(0) ["seqname_format"]=> string(6) "%s_seq" ["autofree"]=> bool(false) ["portability"]=> int(0) ["optimize"]=> string(11) "performance" } ["last_parameters"]=> array(0) { } ["prepare_tokens"]=> array(0) { } ["prepare_types"]=> array(0) { } ["prepared_queries"]=> array(0) { } ["_last_query_manip"]=> bool(false) ["_next_query_manip"]=> bool(false) ["_debug"]=> bool(false) ["_default_error_mode"]=> NULL ["_default_error_options"]=> NULL ["_default_error_handler"]=> string(0) "" ["_error_class"]=> string(8) "DB_Error" ["_expected_errors"]=> array(0) { } } ["type"]=> string(2) "->" ["args"]=> array(7) { [0]=> NULL [1]=> int(-24) [2]=> NULL [3]=> NULL [4]=> string(249) " [nativecode=pg_connect(): Unable to connect to PostgreSQL server: could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?]" [5]=> string(8) "DB_Error" [6]=> bool(true) } } [3]=> array(7) { ["file"]=> string(27) "/usr/share/php/DB/pgsql.php" ["line"]=> int(289) ["function"]=> string(10) "raiseError" ["class"]=> string(9) "DB_common" ["object"]=> object(DB_pgsql)#1 (28) { ["phptype"]=> string(5) "pgsql" ["dbsyntax"]=> string(5) "pgsql" ["features"]=> array(7) { ["limit"]=> string(5) "alter" ["new_link"]=> string(5) "4.3.0" ["numrows"]=> bool(true) ["pconnect"]=> bool(true) ["prepare"]=> bool(false) ["ssl"]=> bool(true) ["transactions"]=> bool(true) } ["errorcode_map"]=> array(0) { } ["connection"]=> bool(false) ["dsn"]=> array(9) { ["phptype"]=> string(5) "pgsql" ["dbsyntax"]=> string(5) "pgsql" ["username"]=> string(0) "" ["password"]=> bool(false) ["protocol"]=> string(3) "tcp" ["hostspec"]=> string(0) "" ["port"]=> bool(false) ["socket"]=> bool(false) ["database"]=> string(9) "nominatim" } ["autocommit"]=> bool(true) ["transaction_opcount"]=> int(0) ["affected"]=> int(0) ["row"]=> array(0) { } ["_num_rows"]=> array(0) { } ["fetchmode"]=> int(1) ["fetchmode_object_class"]=> string(8) "stdClass" ["was_connected"]=> NULL ["last_query"]=> string(0) "" ["options"]=> array(8) { ["result_buffering"]=> int(500) ["persistent"]=> bool(false) ["ssl"]=> bool(false) ["debug"]=> int(0) ["seqname_format"]=> string(6) "%s_seq" ["autofree"]=> bool(false) ["portability"]=> int(0) ["optimize"]=> string(11) "performance" } ["last_parameters"]=> array(0) { } ["prepare_tokens"]=> array(0) { } ["prepare_types"]=> array(0) { } ["prepared_queries"]=> array(0) { } ["_last_query_manip"]=> bool(false) ["_next_query_manip"]=> bool(false) ["_debug"]=> bool(false) ["_default_error_mode"]=> NULL ["_default_error_options"]=> NULL ["_default_error_handler"]=> string(0) "" ["_error_class"]=> string(8) "DB_Error" ["_expected_errors"]=> array(0) { } } ["type"]=> string(2) "->" ["args"]=> array(5) { [0]=> int(-24) [1]=> NULL [2]=> NULL [3]=> NULL [4]=> string(235) "pg_connect(): Unable to connect to PostgreSQL server: could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?" } } [4]=> array(7) { ["file"]=> string(21) "/usr/share/php/DB.php" ["line"]=> int(556) ["function"]=> string(7) "connect" ["class"]=> string(8) "DB_pgsql" ["object"]=> object(DB_pgsql)#1 (28) { ["phptype"]=> string(5) "pgsql" ["dbsyntax"]=> string(5) "pgsql" ["features"]=> array(7) { ["limit"]=> string(5) "alter" ["new_link"]=> string(5) "4.3.0" ["numrows"]=> bool(true) ["pconnect"]=> bool(true) ["prepare"]=> bool(false) ["ssl"]=> bool(true) ["transactions"]=> bool(true) } ["errorcode_map"]=> array(0) { } ["connection"]=> bool(false) ["dsn"]=> array(9) { ["phptype"]=> string(5) "pgsql" ["dbsyntax"]=> string(5) "pgsql" ["username"]=> string(0) "" ["password"]=> bool(false) ["protocol"]=> string(3) "tcp" ["hostspec"]=> string(0) "" ["port"]=> bool(false) ["socket"]=> bool(false) ["database"]=> string(9) "nominatim" } ["autocommit"]=> bool(true) ["transaction_opcount"]=> int(0) ["affected"]=> int(0) ["row"]=> array(0) { } ["_num_rows"]=> array(0) { } ["fetchmode"]=> int(1) ["fetchmode_object_class"]=> string(8) "stdClass" ["was_connected"]=> NULL ["last_query"]=> string(0) "" ["options"]=> array(8) { ["result_buffering"]=> int(500) ["persistent"]=> bool(false) ["ssl"]=> bool(false) ["debug"]=> int(0) ["seqname_format"]=> string(6) "%s_seq" ["autofree"]=> bool(false) ["portability"]=> int(0) ["optimize"]=> string(11) "performance" } ["last_parameters"]=> array(0) { } ["prepare_tokens"]=> array(0) { } ["prepare_types"]=> array(0) { } ["prepared_queries"]=> array(0) { } ["_last_query_manip"]=> bool(false) ["_next_query_manip"]=> bool(false) ["_debug"]=> bool(false) ["_default_error_mode"]=> NULL ["_default_error_options"]=> NULL ["_default_error_handler"]=> string(0) "" ["_error_class"]=> string(8) "DB_Error" ["_expected_errors"]=> array(0) { } } ["type"]=> string(2) "->" ["args"]=> array(2) { [0]=> array(9) { ["phptype"]=> string(5) "pgsql" ["dbsyntax"]=> string(5) "pgsql" ["username"]=> string(0) "" ["password"]=> bool(false) ["protocol"]=> string(3) "tcp" ["hostspec"]=> string(0) "" ["port"]=> bool(false) ["socket"]=> bool(false) ["database"]=> string(9) "nominatim" } [1]=> bool(false) } } [5]=> array(6) { ["file"]=> string(53) "/srv/nominatim.openstreetmap.org/nominatim/lib/db.php" ["line"]=> int(7) ["function"]=> string(7) "connect" ["class"]=> string(2) "DB" ["type"]=> string(2) "::" ["args"]=> array(2) { [0]=> string(19) "pgsql://@/nominatim" [1]=> bool(false) } } [6]=> array(4) { ["file"]=> string(61) "/srv/nominatim.openstreetmap.org/nominatim/website/search.php" ["line"]=> int(10) ["function"]=> string(5) "getDB" ["args"]=> array(0) { } } } ["callback"]=> NULL } DB Error: connect failed 

Best regards

Michael
(Nakaner)

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #5934.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.