Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10629 closed defect (fixed)

Can't download Plugin list - HTTP response code 500 because of "NameError: global name 'fname' is not defined"

Reported by: josmticket@… Owned by: team
Priority: major Milestone:
Component: Trac Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Select Menu Edit > Preferences
  2. Go to the Plugins Tab
  3. Click "Download List"

What is the expected result?

Available Plugins are being displayed (I guess?)

What happens instead?

A Window informs me about a "Plugin list download error":

JOSM failed to download plugin list:

Server returned HTTP response code: 500 for URL:
https://josm.openstreetmap.de/plugin

Details:

(Content of the details window attached as details.html)

Please provide any additional information below. Attach a screenshot if
possible.

JOSM latest was installed as described at https://josm.openstreetmap.de/wiki/Download#Ubuntu

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-08 01:35:06
Last Changed Author: Don-vip
Revision: 7608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-08 00:01:23 +0200 (Wed, 08 Oct 2014)
Last Changed Rev: 7608

Identification: JOSM/1.5 (7608 en) Linux Ubuntu 14.04.1 LTS
Memory Usage: 1326 MB / 1747 MB (721 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.2-3~14.04
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/das-g/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found


Last errors/warnings:
- E: Server returned HTTP response code: 500 for URL: https://josm.openstreetmap.de/plugin-icons.zip - Details:
- E: Server returned HTTP response code: 500 for URL: https://josm.openstreetmap.de/plugin - Details:
- E: Server returned HTTP response code: 500 for URL: https://josm.openstreetmap.de/plugin-icons.zip - Details:
- E: Server returned HTTP response code: 500 for URL: https://josm.openstreetmap.de/plugin - Details:
- E: Server returned HTTP response code: 500 for URL: https://josm.openstreetmap.de/plugin-icons.zip - Details:

Attachments (2)

Can't download Plugin list - HTTP response code 500 because of "NameError: global name 'fname' is not defined".png (238.1 KB) - added by josmticket@… 7 years ago.
Screenshot of error message window
details.html (6.2 KB) - added by josmticket@… 7 years ago.
Content of the "Details" text field of the error message window

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by josmticket@…

Attachment: details.html added

Content of the "Details" text field of the error message window

comment:1 Changed 7 years ago by skyper

Priority: normalmajor

Did reproduce with "update plugins".

comment:2 Changed 7 years ago by skyper

As a workaround you can manually download and install the plugins. Have a look at Plugins.

comment:3 Changed 7 years ago by stoecker

Resolution: fixed
Status: newclosed

Sorry. Fixed it. Small error in the last server code change.

comment:4 Changed 7 years ago by Don-vip

Component: CoreTrac

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.