Modify

Opened 6 years ago

Closed 6 years ago

#10577 closed defect (duplicate)

continousDownload make exception

Reported by: LS Owned by: Gnonthgol
Priority: normal Milestone:
Component: Plugin continuosDownload Version: latest
Keywords: template_report github Cc:

Description

What steps will reproduce the problem?

  1. use continousDownload plugin to autamtic load OSM datas and latest version 7588
  2. load new map from OSM or move loaded map
  3. when plugin begin to download, JOSM throws exception about error

What is the expected result?
Automaticly load datas from OSM when map is moved to not yet downloaded areas. Previous versions didn't have this problem.

What happens instead?
Throwed exception and don't load map.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-29 22:12:08
Last Changed Author: Don-vip
Revision: 7588
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-29 23:52:43 +0200 (Mon, 29 Sep 2014)
Last Changed Rev: 7588

Identification: JOSM/1.5 (7588 cs) Windows 7 64-Bit
Memory Usage: 676 MB / 989 MB (320 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- DirectDownload (30416)
- DirectUpload (30416)
- FixAddresses (30416)
- HouseNumberTaggingTool (30416)
- OpeningHoursEditor (30609)
- RoadSigns (30495)
- Tracer (30416)
- Tracer2 (30416)
- continuosDownload (28565)
- czechaddress (30416)
- editgpx (30634)
- gpsblam (30444)
- gpxfilter (30416)
- junctionchecking (30664)
- mapdust (30502)
- measurement (30641)
- merge-overlap (30416)
- namemanager (30416)
- notes (v0.9.4)
- pdfimport (30416)
- pointInfo (30470)
- turnlanes (30416)
- turnrestrictions (30651)
- waydownloader (30693)
- waypoint_search (30416)

Last errors/warnings:
- E: java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/osm/DataSource. Přičina: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.osm.DataSource
- E: java.lang.IllegalStateException: Timer already cancelled.

java.lang.IllegalStateException: Timer already cancelled.
	at java.util.Timer.sched(Unknown Source)
	at java.util.Timer.schedule(Unknown Source)
	at org.openstreetmap.josm.plugins.continuosDownload.DownloadPlugin.zoomChanged(DownloadPlugin.java:87)
	at org.openstreetmap.josm.gui.NavigatableComponent.fireZoomChanged(NavigatableComponent.java:134)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomNoUndoTo(NavigatableComponent.java:471)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomTo(NavigatableComponent.java:449)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomToFactor(NavigatableComponent.java:522)
	at org.openstreetmap.josm.gui.MapMover.mouseWheelMoved(MapMover.java:207)
	at java.awt.Component.processMouseWheelEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Keywords: github added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #8836.
Please complain here: https://github.com/Gnonthgol/JOSM-continuos-download/issues/6

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gnonthgol.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.