Modify

Opened 5 years ago

Closed 5 years ago

#10530 closed defect (fixed)

[patch] Wrong Select-Box items for tagging parking fee

Reported by: anonymous Owned by: team
Priority: minor Milestone: 14.10
Component: Internal preset Version:
Keywords: wrong value fee key Cc: simon04

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. select a random car parking
  2. select "Transport -> Car -> Parking" from the Templates-menu, or use the quick link from the properties box
  3. the drop-down list for the "fee"-key offers "yes/no/interval/<nothing>" as values

What is the expected result?
According to the wiki, only the values "yes/no/<nothing>" are specified for the "fee"-key. "Interval" is not a valid value for the "fee"-key.

What happens instead?
See step 3.

Please provide any additional information below. Attach a screenshot if possible.
Error might be copy&paste error, because the combination of values is the same as for the "supervised" key (where "interval" is allowed).

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-08-31 21:55:55
Last Changed Author: Don-vip
Revision: 7480
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-08-31 23:51:24 +0200 (Sun, 31 Aug 2014)
Last Changed Rev: 7480

Identification: JOSM/1.5 (7480 de) Windows 7 64-Bit
Memory Usage: 365 MB / 989 MB (154 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- FixAddresses (30416)
- HouseNumberTaggingTool (30416)
- OpeningHoursEditor (30609)
- RoadSigns (30495)
- buildings_tools (30485)
- imagery_offset_db (30534)
- namemanager (30416)
- notes (v0.9.4)
- public_transport (30416)
- reverter (30521)
- tageditor (30488)
- terracer (30614)
- turnlanes (30416)
- turnrestrictions (30454)

Last errors/warnings:
- W: Veraltetes 'canvas{background-color}' in 'http://josm.openstreetmap.de/josmfile?page=Styles/Fixme&style' entdeckt, welches in Kürze entfernt wird. Verwenden Sie stattdessen 'fill-color'.

Attachments (3)

josm_10530.diff (16.6 KB) - added by skyper 5 years ago.
patch
josm_10530v2.diff (16.4 KB) - added by skyper 5 years ago.
patch version 2
deprecated.mapcss.diff (513 bytes) - added by skyper 5 years ago.
validator patch

Download all attachments as: .zip

Change History (19)

comment:1 Changed 5 years ago by Don-vip

Component: CoreInternal preset
Description: modified (diff)
Resolution: invalid
Status: newclosed

Wiki is not up to date. See osmwiki:Key:fee where interval is a valid value. We offer this value since r3573.

comment:2 in reply to:  1 ; Changed 5 years ago by skyper

Replying to Don-vip:

Wiki is not up to date. See osmwiki:Key:fee where interval is a valid value. We offer this value since r3573.

It is written in italic and proposed to use the opening_hours format. interval is only used ~500 times according to taginfo where as you find a lot of different real intervals.

Offering some intervals in opening_hours syntax would be an enhancement.

comment:3 Changed 5 years ago by Don-vip

Resolution: invalid
Status: closedreopened

Exact, closing too fast.

comment:4 in reply to:  2 ; Changed 5 years ago by Don-vip

Replying to skyper:

Offering some intervals in opening_hours syntax would be an enhancement.

I would accept a patch that changes that :) We should also deprecate the old fee=interval value we offered for years.

Changed 5 years ago by skyper

Attachment: josm_10530.diff added

patch

comment:5 in reply to:  4 ; Changed 5 years ago by skyper

Replying to Don-vip:

Replying to skyper:

Offering some intervals in opening_hours syntax would be an enhancement.

I would accept a patch that changes that :)

Here you go:

  • changed all values interval to proper values
  • new chunk for internet access
  • small updates of all *_parking
  • added operator and opening_hours to some amenities

We should also deprecate the old fee=interval value we offered for years.

Also lit=interval and supervised=interval.

comment:6 Changed 5 years ago by skyper

Summary: Wrong Select-Box items for tagging parking fee[patch] Wrong Select-Box items for tagging parking fee

comment:7 in reply to:  5 ; Changed 5 years ago by skyper

Cc: simon04 added

Replying to skyper:

Replying to Don-vip:

Replying to skyper:

Offering some intervals in opening_hours syntax would be an enhancement.

I would accept a patch that changes that :)

Here you go:

  • changed all values interval to proper values
  • new chunk for internet access
  • small updates of all *_parking
  • added operator and opening_hours to some amenities

We should also deprecate the old fee=interval value we offered for years.

Also lit=interval and supervised=interval.

According to taginfo especially lit=interval is used quite a lot.

Strange thought, that only Vespucci is supporting fee=interval (https://taginfo.openstreetmap.org/tags/fee=interval#projects). Is the defaultpresets parsed completely (combo and multiselect) ?

comment:8 Changed 5 years ago by Don-vip

Mai-Sep in your patch should be May-Sep I assume?

Changed 5 years ago by skyper

Attachment: josm_10530v2.diff added

patch version 2

comment:9 in reply to:  8 Changed 5 years ago by skyper

Replying to Don-vip:

Mai-Sep in your patch should be May-Sep I assume?

Of course !

Did update the patch.

comment:10 in reply to:  7 Changed 5 years ago by skyper

Replying to skyper:

According to taginfo especially lit=interval is used quite a lot.

Strange thought, that only Vespucci is supporting fee=interval (https://taginfo.openstreetmap.org/tags/fee=interval#projects). Is the defaultpresets parsed completely (combo and multiselect) ?

Totally, overlooked that there is still work to todo in #10512.

@simon:
Could you have a look at Vespucci or am I wrong in my guess that you are involved in this project ?

comment:11 Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 7620/josm:

fix #10530 - preset update (patch by skyper) + deprecate fee=interval

comment:12 Changed 5 years ago by Don-vip

Milestone: 14.10

comment:13 in reply to:  7 ; Changed 5 years ago by skyper

Replying to skyper:

According to taginfo especially lit=interval is used quite a lot.

Please also include a warning for this combination (and supervised), thanks. See taginfo numbers.

comment:14 Changed 5 years ago by skyper

Resolution: fixed
Status: closedreopened

Changed 5 years ago by skyper

Attachment: deprecated.mapcss.diff added

validator patch

comment:15 in reply to:  13 Changed 5 years ago by skyper

Replying to skyper:

Replying to skyper:

According to taginfo especially lit=interval is used quite a lot.

Please also include a warning for this combination (and supervised), thanks. See taginfo numbers.

Please, find attached patch which adds the two additional warnings. Hope I did used correct syntax.

comment:16 Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 7623/josm:

fix #10530 - deprecate other interval tags (patch by skyper)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.