Modify

Opened 5 years ago

Closed 5 years ago

#10496 closed defect (fixed)

Empty chunks in presets cause crash and hang

Reported by: malcolmh Owned by: team
Priority: normal Milestone: 14.09
Component: Core Version:
Keywords: preset Cc:

Description (last modified by Don-vip)

ERROR: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.util.NoSuchElementException. Cause: java.util.concurrent.ExecutionException: java.util.NoSuchElementException. Cause: java.util.NoSuchElementException
java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.util.NoSuchElementException
	at org.openstreetmap.josm.Main.<init>(Main.java:604)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:86)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:421)
Caused by: java.util.concurrent.ExecutionException: java.util.NoSuchElementException
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:188)
	at org.openstreetmap.josm.Main.<init>(Main.java:601)
	... 2 more
Caused by: java.util.NoSuchElementException
	at java.util.ArrayList$Itr.next(ArrayList.java:834)
	at org.openstreetmap.josm.gui.tagging.TaggingPresetReader.readAll(TaggingPresetReader.java:115)
	at org.openstreetmap.josm.gui.tagging.TaggingPresetReader.readAll(TaggingPresetReader.java:236)
	at org.openstreetmap.josm.gui.tagging.TaggingPresetReader.readAll(TaggingPresetReader.java:263)
	at org.openstreetmap.josm.gui.tagging.TaggingPresetReader.readFromPreferences(TaggingPresetReader.java:299)
	at org.openstreetmap.josm.gui.tagging.TaggingPresets.readFromPreferences(TaggingPresets.java:36)
	at org.openstreetmap.josm.gui.tagging.TaggingPresets.initialize(TaggingPresets.java:43)
	at org.openstreetmap.josm.Main$3.initialize(Main.java:578)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:642)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:626)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by malcolmh

Keywords: preset added
Summary: Empty chunks cause crash and hangEmpty chunks in presets cause crash and hang

comment:2 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 5 years ago by Don-vip

Milestone: 14.09

comment:4 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7516/josm:

fix #10496 - NoSuchElementException with empty chunk in preset

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.