Modify

Opened 5 years ago

Closed 2 years ago

Last modified 2 years ago

#10495 closed enhancement (fixed)

New transformation formulas support in opendata

Reported by: naoliv Owned by: Don-vip
Priority: major Milestone:
Component: Plugin opendata Version:
Keywords: projection esri shapefile Cc:

Description (last modified by naoliv)

While opening the attached shapefile we can see this:

JOSM was unable to find a strict mathematical transformation between 'GCS_SIRGAS_2000' and WGS84.

But from http://www.ibge.gov.br/english/geociencias/geodesia/pmrg/faq.shtm#15 we have:

15. Are there transformation parameters between WGS84 and SIRGAS2000?

There are not such parameters between SIRGAS2000 and WGS84 because they are practically equal, that is,
DX = 0, DY = 0 and DZ = 0. 

So opendata could support SIRGAS2000 without doing anything special (and without giving any kind of warning).

Also, at the same page we have two more coordinate transformations that could be useful for opendata:

Since the establishment of GPS(Global Positioning System), its Geodetic
Reference System (WGS84) has been updated three times. The purpose was to
align it to ITRFyy, the most accurate ITRS realization. The latest update
was named WGS84 (G1150), adopted in the GPS system since January 20th of
2002.
The SAD69 / WGS84 transformation parameters, published in the Resolution of
the Presidency of IBGE number 23, of 21/02/89 (R.PR 23/89), are valid to
transform the coordinates between SAD69 / WGS84 in GPS observations
conducted in the period from 01/01/1987 to 01/01/1994.

WGS84 to SAD69:
DX = +66.87 m
DY = -4.37 m
DZ = +38.52 m

The SAD69 / SIRGAS2000 parameters, used in TCGeo and ProGriD (option: SAD69
Doppler Technique or GPS) and published in the Resolution of the Presidency
of IBGE number 1, of 25/02/2005 (R.PR 01/05), are valid to transform the
coordinates between SAD69 / WGS84 and SAD69 / SIRGAS2000 in GPS
observations conducted after 1994.

SIRGAS2000(WGS84 (G1150)) to SAD69:
DX = +67.35 m
DY = -3.88 m
DZ = +38.22 m

JOSM:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-09 01:33:35
Last Changed Author: Don-vip
Revision: 7514
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-08 23:45:36 +0200 (Mon, 08 Sep 2014)
Last Changed Rev: 7514

Identification: JOSM/1.5 (7514 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 247 MB / 4029 MB (48 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.2-2
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Plugins:
- AddrInterpolation (30416)
- Create_grid_of_ways (30416)
- FixAddresses (30416)
- ImageryCache (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- SimplifyArea (30624)
- buildings_tools (30485)
- editgpx (30416)
- geochat (30513)
- geotools (30569)
- graphview (30416)
- jts (30416)
- merge-overlap (30416)
- notes (v0.9.4)
- opendata (30607)
- pdfimport (30416)
- poly (30495)
- reverter (30521)
- tagging-preset-tester (30592)
- todo (29154)
- turnrestrictions (30454)
- undelete (30416)
- utilsplugin2 (30460)

Attachments (1)

sp.tar.bz2 (1.5 MB) - added by naoliv 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by naoliv

Attachment: sp.tar.bz2 added

comment:1 Changed 5 years ago by naoliv

Description: modified (diff)

comment:2 Changed 5 years ago by Don-vip

Status: newassigned

comment:3 Changed 5 years ago by Don-vip

I have created a feature request to GeoTools for a related message: https://jira.codehaus.org/browse/GEOT-5062

comment:4 Changed 2 years ago by Don-vip

Keywords: projection esri shapefile added
Priority: normalmajor

comment:5 Changed 2 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o33356:33357].

I have not added the information concerning your projections only bur rather included the whole ESRI database (more than 7000 projections) obtained from Github (Apache 2.0), so this is a huge enhancement :)

comment:6 Changed 2 years ago by Don-vip

Ticket #12171 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.