Modify

Opened 5 years ago

Closed 5 years ago

#10413 closed defect (duplicate)

AssertionError when adding new property

Reported by: cov@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by skyper)

When editing a node with several addr:field already set, I clicked add to try to add a survey:date value, but JOSM crashed when I clicked the Add button.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-28 22:35:35
Last Changed Author: Don-vip
Revision: 7347
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-29 00:32:15 +0200 (Tue, 29 Jul 2014)
Last Changed Rev: 7347

Identification: JOSM/1.5 (7347 en) Linux elementary OS Luna
Memory Usage: 135 MB / 1758 MB (17 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-4ubuntu1~0.12.04.1
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found


java.lang.AssertionError: Point LatLon[lat=0.0,lon=0.0] should be inside [ x: -90.0 -> -45.0, y: 0.0 -> 22.5 ]
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.getBounded(GeoPropertyIndex.java:108)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.getBounded(GeoPropertyIndex.java:154)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.get(GeoPropertyIndex.java:100)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.get(GeoPropertyIndex.java:102)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.get(GeoPropertyIndex.java:102)
	at org.openstreetmap.josm.tools.GeoPropertyIndex.get(GeoPropertyIndex.java:70)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.isRightHandTraffic(RightAndLefthandTraffic.java:64)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$Functions.is_right_hand_traffic(ExpressionFactory.java:618)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.appliesImpl(Condition.java:406)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.applies(Condition.java:380)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$AbstractSelector.matches(Selector.java:420)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.apply(MapCSSStyleSource.java:387)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.generateStyles(ElemStyles.java:328)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.getNodeIcon(MapPaintStyles.java:145)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper$AddTagsDialog.suggestRecentlyAddedTags(TagEditHelper.java:687)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper$AddTagsDialog.<init>(TagEditHelper.java:607)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper.addTag(TagEditHelper.java:129)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog$AddAction.actionPerformed(PropertiesDialog.java:1008)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3311)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (1)

bug.osm (192 bytes) - added by cov@… 5 years ago.
Single empty node

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by skyper

Description: modified (diff)
Summary: Crash when adding new propertyAssertionError when adding new property

Does it always happen ?
Could you please tell us the node id or attach a small example file.

Thanks

Changed 5 years ago by cov@…

Attachment: bug.osm added

Single empty node

comment:2 Changed 5 years ago by cov@…

It seems to be consistently reproducible. I worked around it by using control+shift+v.

comment:3 in reply to:  2 Changed 5 years ago by skyper

Replying to cov@…:

It seems to be consistently reproducible. I worked around it by using control+shift+v.

First your were talking about an existing node with some tags and now you did upload a local created node without tags.

Anyway, I can not reproduce.

  • What projection do you use ? (See Map Settings)
  • Did you try it with a new/empty preference directory (default settings) ? ( moving $HOME/.josm or the command line option -Djosm.home will do it)
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-08-22 01:36:32
Last Changed Author: Don-vip
Revision: 7437
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-08-22 00:58:24 +0200 (Fri, 22 Aug 2014)
Last Changed Rev: 7437

Identification: JOSM/1.5 (7437 en) Linux Debian GNU/Linux 7.6 (wheezy)
Memory Usage: 211 MB / 882 MB (94 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-2~deb7u1
Program arguments: [bug.osm]
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30519)
- conflation (0.1.7)
- imagery-xml-bounds (30495)
- jts (30416)
- mirrored_download (30495)
- notes (v0.9.3)
- photoadjust (30428)
- reverter (30521)
- terracer (30416)
- todo (29154)
- undelete (30416)
- utilsplugin2 (30460)
- wikipedia (30449)

Last errors/warnings:
- W: Detected deprecated 'canvas{background-color}' in 'https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip' which will be removed shortly. Use 'fill-color' instead.

comment:4 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10328.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.