Modify

Opened 6 years ago

Closed 6 years ago

#10347 closed defect (duplicate)

Keyboard input is ignored after adding/modifying several points

Reported by: Zian Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: java8 javabug 8u20 Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM.
  2. Add/modify/delete at least 10 or so points.
  3. Hit ALT+A to add a tag
  4. Try typing.

What is the expected result?
The keyboard input to appear in the textbox.

What happens instead?
Nothing.

Please provide any additional information below. Attach a screenshot if
possible.
This is an intermittent issue. In the past, I've worked around it by just accepting the default values in the "Add Value" dialog box and then editing it later. Somehow, double-clicking on the key/value pair and launching the same dialog re-enables keyboard input. However, this time around, I got a full blown JOSM bug popup.

My computer is a ThinkPad T400 running Windows 7 x64 with ATI switchable graphics.

Revision: 7347
Repository Root: http://josm.openstreetmap.de/svn
Last Changed Author: Don-vip
Last Changed Date: 2014-07-29 00:32:15 +0200 (Tue, 29 Jul 2014)
Build-Date: 2014-07-28 22:35:35
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7347

Identification: JOSM/1.5 (7347 en) Windows 7 64-Bit
Memory Usage: 168 MB / 247 MB (65 MB allocated, but free)
Java version: 1.8.0_05, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.policy=file:C:\Program Files (x86)\Java\jre8\lib\security\javaws.policy, -DtrustProxy=true, -Xverify:remote, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Users\Zian\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\56\1ee8cfb8-6910fd8a, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Xbootclasspath/a:C:\Program Files (x86)\Java\jre8\lib\javaws.jar;C:\Program Files (x86)\Java\jre8\lib\deploy.jar;C:\Program Files (x86)\Java\jre8\lib\plugin.jar, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=55840, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=-Djava.util.Arrays.useLegacyMergeSort=true -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp]
Dataset consistency test: No problems found

Plugin: imagery_offset_db (30534)
Plugin: measurement (30416)
Plugin: notes (v0.9.3)

java.util.NoSuchElementException
	at java.util.LinkedList.getFirst(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.repostIfFollowsKeyEvents(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$400(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.SequencedEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$400(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Keywords: java8 javabug 8u20 added; template_report removed
Resolution: duplicate
Status: newclosed

Closed as duplicate of #10038.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.