Modify

Opened 8 years ago

Closed 8 years ago

#10298 closed defect (duplicate)

Cannot open GPX file

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Core Version:
Keywords: gpx regression Cc: akks

Description

What steps will reproduce the problem?

  1. Start JOSM
  2. Open a gpx file

What is the expected result?

What happens instead?
The GPX track is not displayed, and instead there is an Unexpected Exception. This happens for GPX files I have been able to open in earlier versions of JOSM (v7252 - have not tried any other).

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-21 01:35:49
Last Changed Author: Don-vip
Revision: 7321
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-21 01:51:53 +0200 (Mon, 21 Jul 2014)
Last Changed Rev: 7321

Identification: JOSM/1.5 (7321 en) Linux Ubuntu 14.04 LTS
Memory Usage: 213 MB / 910 MB (119 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-1ubuntu1
VM arguments: [-Xmx1024M]

Plugin: colorscheme (30416)
Plugin: lakewalker (30416)
Plugin: measurement (30416)
Plugin: openvisible (30416)
Plugin: pbf (30495)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.layer.gpx.GpxDrawHelper.drawPoints(GpxDrawHelper.java:458)
	at org.openstreetmap.josm.gui.layer.gpx.GpxDrawHelper.drawAll(GpxDrawHelper.java:204)
	at org.openstreetmap.josm.gui.layer.GpxLayer.paint(GpxLayer.java:285)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:536)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:607)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:295)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
	at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by Don-vip

Cc: akks added
Keywords: gpx regression added; template_report removed
Milestone: 14.07
Owner: changed from team to anonymous
Status: newneedinfo

Can you please attach one of your gpx files and a screenshot of your GPX drawing preferences? (F12, Display settings, GPS Points). Thanks.

comment:2 Changed 8 years ago by akks

Most likely, this is already fixed in r7323, but needs checking. GPX file would be useful.

comment:3 Changed 8 years ago by anonymous

Bug reporter here. I just tried r7327, and I can confirm the bug is fixed. Thanks!

comment:4 Changed 8 years ago by Don-vip

Milestone: 14.07
Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #10294.
ok great :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.