Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10292 closed defect (fixed)

Session loading fails to parse a log file in NMEA format.

Reported by: bartosomail@… Owned by: team
Priority: minor Milestone: 14.07
Component: Core Version: latest
Keywords: session nmea Cc:

Description

I saved a session which includes a layer for a track log in NMEA format, choosing the option to save gpx data as local file. During session loading, an error notification window "Error loading layer" pops up, with message "Could not load layer 'xxx'. Error is: Parsing data for layer 'xxx' failed".

The same NMEA log loads normally if I instead choose to include gpx data in session file.

Attachments (2)

gns2000.nmea (484.6 KB) - added by bartosomail@… 5 years ago.
nmea log
session.jos (508 bytes) - added by bartosomail@… 5 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by Don-vip

Owner: changed from team to bartosomail@…
Status: newneedinfo

Can you please attach your status report, plus your session and NMEA files? Thanks.

Changed 5 years ago by bartosomail@…

Attachment: gns2000.nmea added

nmea log

Changed 5 years ago by bartosomail@…

Attachment: session.jos added

comment:2 Changed 5 years ago by anonymous

I attached session and NMEA file. Here is the bug report:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-13 01:35:29
Last Changed Author: akks
Revision: 7309
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-12 20:45:45 +0200 (Sat, 12 Jul 2014)
Last Changed Rev: 7309

Identification: JOSM/1.5 (7309 en) Windows 7 64-Bit
Memory Usage: 108 MB / 989 MB (50 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xmx1024M]

Plugin: ImageryCache (30416)
Plugin: ImportImagePlugin (30416)
Plugin: OpeningHoursEditor (30519)
Plugin: PicLayer (30436)
Plugin: SimplifyArea (30416)
Plugin: buildings_tools (30485)
Plugin: dataimport (30416)
Plugin: download_along (30416)
Plugin: editgpx (30416)
Plugin: geochat (30513)
Plugin: geotools (30416)
Plugin: gpxfilter (30416)
Plugin: jts (30416)
Plugin: log4j (30416)
Plugin: measurement (30416)
Plugin: merge-overlap (30416)
Plugin: mirrored_download (30495)
Plugin: photo_geotagging (30462)
Plugin: photoadjust (30428)
Plugin: public_transport (30416)
Plugin: reltoolbox (30416)
Plugin: reverter (30521)
Plugin: tag2link (30416)
Plugin: terracer (30416)
Plugin: turnrestrictions (30454)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30460)
Plugin: waydownloader (30416)
Plugin: wikipedia (30449)

comment:3 Changed 5 years ago by Don-vip

Owner: changed from bartosomail@… to team
Status: needinfonew

Thanks !

comment:4 Changed 5 years ago by Don-vip

ERROR: java.io.IOException: Parsing data for layer 'gns2000.nmea' failed. Cause: org.xml.sax.SAXParseException: Content is not allowed in prolog.
java.io.IOException: Parsing data for layer 'gns2000.nmea' failed
	at org.openstreetmap.josm.io.GpxImporter.loadLayers(GpxImporter.java:162)
	at org.openstreetmap.josm.io.session.GpxTracksSessionImporter.load(GpxTracksSessionImporter.java:40)
	at org.openstreetmap.josm.io.session.SessionReader.parseJos(SessionReader.java:455)
	at org.openstreetmap.josm.io.session.SessionReader.loadSession(SessionReader.java:603)
	at org.openstreetmap.josm.io.session.SessionReader.loadSession(SessionReader.java:555)
	at org.openstreetmap.josm.actions.SessionLoadAction$Loader.realRun(SessionLoadAction.java:159)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:150)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content is not allowed in prolog.
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:198)
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:177)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:441)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:368)
	at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1436)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:999)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:606)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:117)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:848)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:777)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:648)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(SAXParserImpl.java:332)
	at org.openstreetmap.josm.io.GpxReader.parse(GpxReader.java:537)
	at org.openstreetmap.josm.io.GpxImporter.loadLayers(GpxImporter.java:157)
	... 12 more

comment:5 Changed 5 years ago by Don-vip

Milestone: 14.07

comment:6 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7326/josm:

fix #10292 - allow to load a session with NMEA file + enhance reading/writing unit tests for sessions

comment:7 Changed 5 years ago by Don-vip

In 7327/josm:

see #10292 - cleanup unit test

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.