Modify

Opened 5 years ago

Closed 5 years ago

#10283 closed defect (fixed)

Photo correlation in latest - errors

Reported by: urbanrambler1 Owned by: urbanrambler1
Priority: normal Milestone: 14.07
Component: Core image mapping Version:
Keywords: photo import correlate Cc:

Description

For a couple of weeks the track-related correlated imported photos have been displayed in incorrect positions (in latest). I thought it might be down to my equipment but on loading 'tested' I find that there are no problems and all correlated photos are shown in the correct locations.

Attachments (6)

Screenshot from 2014-07-20 09:33:11.png (69.1 KB) - added by anonymous 5 years ago.
Screenshot from 2014-07-20 09:33:11.2.png (69.1 KB) - added by anonymous 5 years ago.
Latest vs Tested using same GPX data and photograph directory
30Shuttle2.gpx (476.4 KB) - added by urbanrambler1 5 years ago.
GPX file
defect_report.txt (924 bytes) - added by urbanrambler1 5 years ago.
Screenshot from JOSM-latest.png (1.5 MB) - added by urbanrambler1 5 years ago.
Screenshot from standard JOSM.png (564.9 KB) - added by urbanrambler1 5 years ago.

Change History (19)

comment:1 Changed 5 years ago by Don-vip

Owner: changed from holgermappt to anonymous
Status: newneedinfo

Could you please add more info? Attaching your status report, a screenshot and a sample file would be useful.

Changed 5 years ago by anonymous

Changed 5 years ago by anonymous

Latest vs Tested using same GPX data and photograph directory

comment:2 Changed 5 years ago by anonymous

Hi,
Thanks for prompt response. I seem to have exceeded attachments but will add GPX file if needed. How do I generate a status report? The top screen shows Latest, for which the correlate screen omits the ':second' field from the photo of the GPS time although it allows the digits to be entered. Tested has all three time fields shown when it starts the 'correlate from photo' sequence. I hope that you can see where the correlated photos occupy different positions, using the same GPX file and the same photo directory and the same 'correlation time' from a photo.

comment:3 in reply to:  2 Changed 5 years ago by skyper

Replying to anonymous:

Hi,
Thanks for prompt response. I seem to have exceeded attachments but will add GPX file if needed. How do I generate a status report? The top screen shows Latest, for which the correlate screen omits the ':second' field from the photo of the GPS time although it allows the digits to be entered. Tested has all three time fields shown when it starts the 'correlate from photo' sequence. I hope that you can see where the correlated photos occupy different positions, using the same GPX file and the same photo directory and the same 'correlation time' from a photo.

You probably were not relaxed enough, as it seems to me that you unintentionally did upload the same picture twice. Trac is sometimes not that fast, please stay calm.

If you want to by pass "recap" you need to log in. The GPX file or at least an small example makes it much easier to spot the problem.

Please, have a look at the wiki page to find the status report.

Changed 5 years ago by urbanrambler1

Attachment: 30Shuttle2.gpx added

GPX file

Changed 5 years ago by urbanrambler1

Attachment: defect_report.txt added

comment:4 Changed 5 years ago by urbanrambler1

In the first photo (of GPS device) it was showing 10:11:09, which was used to correlate. Josm-latest updates daily, so version in report is a couple of days later.

comment:5 Changed 5 years ago by holgermappt

Component: Plugin photoadjustCore image mapping

Hi,

I changed the component to Core image mapping as this is not related to the PhotoAdjust plugin. I don't know exactly that "image mapping" refers to, but it sounds reasonable, at least to me.

I can confirm that there is a regression in the image to GPX correlation dialog (Geotagged images -> Correlate to GPX -> Use photo of an accurate clock -> Gps time (read from the above photo)). Only hours and minutes can be specified. Seconds can be entered (in the German version, the English version complains about a wrong time format), but they are ignored. I tested with JOSM 7319.

Holger

Last edited 5 years ago by holgermappt (previous) (diff)

comment:6 Changed 5 years ago by urbanrambler1

Many thanks for your efforts. I only do photo correlation about weekly, so any more feedback will emerge slowly. I would note that this error 'came to me' via JOSM-latest/plugins updates, because I have been happily using this without problems for a year now, and have not altered my setup.
With regard to your second paragraph, this 'missing seconds' feature is very recent, so is presumably related to whatever causes the malfunction.

comment:7 Changed 5 years ago by Don-vip

Milestone: 14.07
Owner: changed from anonymous to team
Status: needinfonew

ok thanks for the info it might be a regression of r7299.

comment:8 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7320/josm:

fix #10283 - wrong time format in GPX/images layer leading to wrong correlation (regression from r7299)

Changed 5 years ago by urbanrambler1

Changed 5 years ago by urbanrambler1

comment:9 in reply to:  8 Changed 5 years ago by anonymous

Replying to Don-vip:

In 7320/josm:

fix #10283 - wrong time format in GPX/images layer leading to wrong correlation (regression from r7299)

This problem is back again. JOSM 'latest' is showing incorrect positions whilst 'tested' works OK. I'm fairly sure that the problem was sorted, but it seems to have been reintroduced (probably with the latest update today).

comment:10 Changed 5 years ago by skyper

Resolution: fixed
Status: closedreopened

Please, reopen a ticket otherwise your comment/problem might get lost.

Could you try with the built of latest of the last days to find the problematic change ? You'll find them under download.
Thanks.

comment:11 Changed 5 years ago by Don-vip

Owner: changed from team to urbanrambler1
Reporter: changed from anonymous to urbanrambler1
Status: reopenedneedinfo

I cannot reproduce. The reintroduction of the bug is unlikely as we didn't touch this part of code again.
Can you please try with recent versions like skyper said, plus attaching your status report and give us a complete step sby step reproduction method, with sample gpx and image files, thanks?

comment:12 Changed 5 years ago by anonymous

Hi, thanks for response. Unfortunately I can't reproduce it either now, so I'll withdraw my bug re-notification.

comment:13 Changed 5 years ago by skyper

Resolution: fixed
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain urbanrambler1.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.