Modify

Opened 5 years ago

Closed 5 years ago

#10242 closed defect (fixed)

Josm does not start anymore

Reported by: hotelsierra Owned by: team
Priority: normal Milestone: 14.07
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Trying to start the programme via web start
  2. Trying to sart programme after complete new installation of JOSM locally

What is the expected result?

What happens instead?

Error message and shut down of starting process. Update of plugins not possible because JOSM did not finish the startup procedure

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-03 22:03:52
Last Changed Author: Don-vip
Revision: 7287
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-04 00:00:19 +0200 (Fri, 04 Jul 2014)
Last Changed Rev: 7287

Identification: JOSM/1.5 (7287 de) Windows 8 64-Bit
Memory Usage: 43 MB / 494 MB (11 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xms16m, -Xmx512m]

Plugin: DirectUpload
Plugin: RoadSigns
Plugin: SeaMapEditor
Plugin: Tracer2
Plugin: editgpx (30414)
Plugin: imageryadjust
Plugin: measurement
Plugin: merge-overlap
Plugin: openstreetbugs (30413)
Plugin: print
Plugin: turnlanes (30413)
Plugin: turnrestrictions

java.lang.NoClassDefFoundError: org/openstreetmap/josm/io/MirroredInputStream
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:334)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:559)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:624)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:664)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:408)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.io.MirroredInputStream
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 7 more

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by stoecker

@Don-Vip:

a bug in plugin loader? It should not prevent loading the main program, when we have an old plugin.

comment:2 Changed 5 years ago by Don-vip

Not a regression at least we didn't touch anything in plugin code recently.

comment:3 in reply to:  2 Changed 5 years ago by Don-vip

Replying to Don-vip:

Not a regression at least we didn't touch anything in plugin code recently.

... or maybe I reworked a Java 7 exception handling badly, maybe NoClassDefFoundError was catched before and is not anymore.

comment:4 Changed 5 years ago by Don-vip

Milestone: 14.07

comment:5 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7294/josm:

fix #10242 - catch NoClassDefFoundError when ClassNotFoundException is catched

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.