Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10197 closed defect (fixed)

StringIndexOutOfBoundsException on check before upload

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.06
Component: Core validator Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. trying to upload some changes

What is the expected result?

Have validator run through its checks and present the results in a new window

What happens instead?

Exception

Please provide any additional information below. Attach a screenshot if possible.

I have run validator manually before on the whole data without problem.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-06-25 01:38:40
Last Changed Author: Don-vip
Revision: 7269
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-06-24 22:49:23 +0200 (Tue, 24 Jun 2014)
Last Changed Rev: 7269

Identification: JOSM/1.5 (7269 en) Linux Debian GNU/Linux 7.5 (wheezy)
Memory Usage: 704 MB / 882 MB (355 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-1~deb7u1
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30416)
Plugin: conflation (0.1.7)
Plugin: imagery-xml-bounds (30495)
Plugin: jts (30416)
Plugin: mirrored_download (30495)
Plugin: notes (v0.9.2)
Plugin: photoadjust (30428)
Plugin: reverter (30436)
Plugin: terracer (30416)
Plugin: todo (29154)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30460)
Plugin: wikipedia (30449)

java.lang.StringIndexOutOfBoundsException: String index out of range: -1
	at java.lang.String.substring(String.java:1911)
	at org.openstreetmap.josm.gui.dialogs.validator.ValidatorTreePanel.buildTree(ValidatorTreePanel.java:166)
	at org.openstreetmap.josm.gui.dialogs.validator.ValidatorTreePanel.setErrors(ValidatorTreePanel.java:328)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:78)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:199)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:222)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:279)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3311)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by skyper

Some more info:

  • I had the validator layer hidden/disabled
  • normal validator run failed with the same exception
  • cloning the layer and uploading did work
    • after that I did not have any problem running validator on the original layer

comment:2 Changed 6 years ago by Don-vip

Owner: changed from team to skyper
Status: newneedinfo

can you please attach your dataset? Thanks.

comment:3 in reply to:  2 Changed 6 years ago by skyper

Replying to Don-vip:

can you please attach your dataset? Thanks.

Damn, sorry, two minutes to late but wait a minute, doesn't JOSM save layers in cache ?

Otherwise I can only tell you the changeset number which should be enough as I do not have any special validator config for upload and the problem should be with a modified object.

comment:4 Changed 6 years ago by Don-vip

Owner: changed from skyper to team
Status: needinfonew

It should be enough thanks

comment:5 Changed 6 years ago by Don-vip

Ticket #10199 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7270/josm:

fix #10197 - StringIndexOutOfBoundsException in validator panel (regression from r7266)

comment:7 Changed 6 years ago by Don-vip

Milestone: 14.06

comment:8 Changed 6 years ago by naoliv

I can't attach it here (it's bigger than the max allowed size), but the data where I am seeing this problem is here:
http://naoliv.iq.unesp.br/osm/10197.osm.bz2

Edit: didn't see that it was already fixed. Sorry.

Last edited 6 years ago by naoliv (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.