Modify

Opened 7 years ago

Closed 7 years ago

#10195 closed defect (fixed)

Warning when empty role found in hiking relations

Reported by: anonymous Owned by: team
Priority: normal Milestone: 14.12
Component: Core validator Version: latest
Keywords: route relation empty role Cc:

Description

In relation type=route and route=hiking we mostly do not use role, but JOSM give me warning "Empty role found".

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by anonymous

Role 'start' is only when it is circle route to mark start.

comment:2 Changed 7 years ago by mkoniecz

related to #10133 (as adding route role is not making validator happy).

comment:3 Changed 7 years ago by skyper

There is often no need for roles in route relations. Please, only check relations which explicitly need roles for all members.

comment:4 Changed 7 years ago by praggel

if change route=hiking to route=foot then no warnings. is this a bug ???

comment:5 in reply to:  4 Changed 7 years ago by skyper

Replying to praggel:

if change route=hiking to route=foot then no warnings. is this a bug ???

at least it is inconsistent and leads to bad tagging as foot is used instead of hiking which is much more in use.

comment:6 Changed 7 years ago by Don-vip

Ticket #10772 has been marked as a duplicate of this ticket.

comment:7 Changed 7 years ago by Don-vip

Keywords: route relation empty role added

comment:8 Changed 7 years ago by Don-vip

Milestone: 14.12
Resolution: fixed
Status: newclosed

Seems to be fixed in r7884.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.