Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10180 closed enhancement (fixed)

"Property values start or end with white space" should be warning level, not information

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 14.06
Component: Core validator Version:
Keywords: Cc:

Description

And it is autofixable.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-06-20 01:36:37
Last Changed Author: simon04
Revision: 7254
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-06-19 11:09:04 +0200 (Thu, 19 Jun 2014)
Last Changed Rev: 7254

Identification: JOSM/1.5 (7254 en) Windows 7 32-Bit
Memory Usage: 86 MB / 247 MB (11 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30416)
Plugin: RoadSigns (30495)
Plugin: buildings_tools (30485)
Plugin: continuosDownload (28565)
Plugin: measurement (30416)
Plugin: notes (v0.9.2)
Plugin: turnrestrictions (30454)
Plugin: wikipedia (30449)

Attachments (0)

Change History (11)

comment:1 Changed 5 years ago by skyper

Ticket #10179 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by skyper

This test should also check keys not only values.

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7268/josm:

fix #10180 - tagchecker: "Property values start or end with white space" set to warning level

comment:4 Changed 5 years ago by Don-vip

Milestone: 14.06

comment:5 in reply to:  2 Changed 5 years ago by skyper

Replying to skyper:

This test should also check keys not only values.

Either we reopen #10180 or this one.

comment:6 Changed 5 years ago by mkoniecz

Resolution: fixed
Status: closedreopened

comment:7 Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Keys are automatically trimmed at save or upload, so there's no specific test to add.

comment:8 in reply to:  7 Changed 5 years ago by skyper

Replying to Don-vip:

Keys are automatically trimmed at save or upload, so there's no specific test to add.

In #10180 the problem was a white space after name which did raise an informational warning about "key not in preset". If white spaces are already trimmed the check should also ignore them. (-> reopening #10180 ?)

comment:9 Changed 5 years ago by Don-vip

#10180 is this ticket, I think you're speaking of another one?

comment:10 Changed 5 years ago by mkoniecz

it is about #10179

comment:11 Changed 5 years ago by Don-vip

OK thanks I understand now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.