Modify

Opened 5 years ago

Closed 13 months ago

#10179 closed defect (fixed)

Invalid "Key 'name ' invalid. - Invalid property key"

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.04
Component: Core validator Version:
Keywords: Cc:

Description (last modified by mkoniecz)

Name seems to be perfectly valid key for hotel.

https://api.openstreetmap.org/node/1940976070

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-06-20 01:36:37
Last Changed Author: simon04
Revision: 7254
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-06-19 11:09:04 +0200 (Thu, 19 Jun 2014)
Last Changed Rev: 7254

Identification: JOSM/1.5 (7254 en) Windows 7 32-Bit
Memory Usage: 243 MB / 247 MB (63 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30416)
Plugin: RoadSigns (30495)
Plugin: buildings_tools (30485)
Plugin: continuosDownload (28565)
Plugin: measurement (30416)
Plugin: notes (v0.9.2)
Plugin: turnrestrictions (30454)
Plugin: wikipedia (30449)

Attachments (2)

whitespace.png (15.1 KB) - added by Klumbumbus 3 years ago.
whitespaces.osm (444 bytes) - added by Klumbumbus 3 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:2 Changed 5 years ago by AlfonZ

There is a space at the end of name key that is causing the trouble.

comment:3 in reply to:  2 Changed 5 years ago by skyper

Replying to AlfonZ:

There is a space at the end of name key that is causing the trouble.

Well, the warning is correct but JOSM could automatically delete white spaces at the end of the key.

comment:4 Changed 5 years ago by mkoniecz

It is autofixable.

comment:5 Changed 5 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10180.

comment:6 Changed 5 years ago by mkoniecz

Not a duplicate, this is about keys, second is about values.

comment:7 in reply to:  6 Changed 5 years ago by skyper

Replying to Bulwersator:

Not a duplicate, this is about keys, second is about values.

Ok, but it is the same issue and the check for keys is needed but there is no problem with the info about invalid property in key.

comment:8 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: closedreopened

I agree this is not clear.

comment:9 Changed 5 years ago by skyper

Still think a similar test like the one for values with an auto-fix option is useful. The autofix on upload only affects modified objects.

comment:10 Changed 3 years ago by Klumbumbus

I read this and #10180. What exactly is still to do?
See attached example file. Validator gives usefull warnings and no infos.


The only point which could be improved is the wording of the first warning. We could add Value of at the beginning, becasue not the key is wrong but the value.

Changed 3 years ago by Klumbumbus

Attachment: whitespace.png added

Changed 3 years ago by Klumbumbus

Attachment: whitespaces.osm added

comment:11 Changed 13 months ago by Klumbumbus

In 13584/josm:

see #10179 - improve validator warning text. Tag fits better than key as for some warnings the value is the culprit.

comment:12 Changed 13 months ago by Klumbumbus

Milestone: 18.04
Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.