Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10172 closed defect (fixed)

Cannot open GPX from URL

Reported by: Zverikk Owned by: team
Priority: normal Milestone: 14.06
Component: Core Version: latest
Keywords: gpx Cc:

Description

What steps will reproduce the problem?

  1. Ctrl+L
  2. Paste any GPX url (e.g. http://www.balticstar.spb.ru/map/2014_200_push.gpx )
  3. Press "Download"

What is the expected result?

Trace is downloaded and opened as a new layer.

What happens instead?

Exception.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-06-20 01:36:37
Last Changed Author: simon04
Revision: 7254
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-06-19 11:09:04 +0200 (Thu, 19 Jun 2014)
Last Changed Rev: 7254

Identification: JOSM/1.5 (7254 ru) Windows 7 64-Bit
Memory Usage: 160 MB / 682 MB (106 MB allocated, but free)
Java version: 1.7.0_17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx768M]

Plugin: HouseNumberTaggingTool (30416)
Plugin: InfoMode (30416)
Plugin: PicLayer (30436)
Plugin: buildings_tools (30485)
Plugin: editgpx (30416)
Plugin: geochat (30416)
Plugin: imagery_offset_db (30416)
Plugin: openstreetbugs (30436)
Plugin: pbf (30495)
Plugin: poly (30495)
Plugin: print (30416)
Plugin: reltoolbox (30416)
Plugin: reverter (30436)
Plugin: tageditor (30488)
Plugin: utilsplugin2 (30460)

org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:201)
	at org.openstreetmap.josm.io.OsmServerLocationReader$GpxParser.parse(OsmServerLocationReader.java:145)
	at org.openstreetmap.josm.io.OsmServerLocationReader$GpxParser.parse(OsmServerLocationReader.java:138)
	at org.openstreetmap.josm.io.OsmServerLocationReader.doParse(OsmServerLocationReader.java:48)
	at org.openstreetmap.josm.io.OsmServerLocationReader.parseRawGps(OsmServerLocationReader.java:100)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$DownloadTask.realRun(DownloadGpsTask.java:113)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:150)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.io.OsmServerReader.uncompressAccordingToContentDisposition(OsmServerReader.java:218)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:195)
	... 13 more

Attachments (0)

Change History (3)

comment:1 by Don-vip, 10 years ago

Milestone: 14.06

comment:2 by Don-vip, 10 years ago

Resolution: fixed
Status: newclosed

In 7267/josm:

fix #10172 - Cannot open GPX from URL without Content-Disposition http header

comment:3 by Zverikk, 10 years ago

Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.