Modify

Opened 6 years ago

Closed 6 years ago

#10050 closed defect (fixed)

align nodes in line moves outer instead of inner node

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.12
Component: Core Version: latest
Keywords: align node in line Cc: Balaitous, richlv, DeeHants, bastiK

Description

What steps will reproduce the problem?

  1. select three nodes in a row all member of the same way (A-C)
  2. align nodes in line

What is the expected result?

The middle node (B) is moved.

What happens instead?

The outer (top) node (C) is moved.

Please provide any additional information below. Attach a screenshot if possible.

Similar happens if you select four node (A-C,K). Both outer nodes (C,K) are moved instead of the two inner ones.
Have a look at attached example file

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-19 01:36:32
Last Changed Author: Don-vip
Revision: 7142
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-18 18:04:18 +0200 (Sun, 18 May 2014)
Last Changed Rev: 7142

Identification: JOSM/1.5 (7142 en) Linux Debian GNU/Linux 7.5 (wheezy)
Memory Usage: 440 MB / 882 MB (162 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-1~deb7u1
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30416)
Plugin: conflation (0.1.6)
Plugin: imagery-xml-bounds (30416)
Plugin: jts (30416)
Plugin: mirrored_download (30436)
Plugin: notes (v0.9.2)
Plugin: photoadjust (30428)
Plugin: reverter (30436)
Plugin: terracer (30416)
Plugin: todo (29154)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30419)
Plugin: wikipedia (30449)

Attachments (1)

align_node.osm (1.7 KB) - added by skyper 6 years ago.
example file

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by skyper

Seems to me that #9605 was almost about the same issue. I understand that it might not be needed for three nodes as I could simply select the middle node but for four nodes this will not work. I need to define some fixed nodes which had been the two outer ones for quite some time.

Changed 6 years ago by skyper

Attachment: align_node.osm added

example file

comment:2 Changed 6 years ago by Balaitous

Strange! I will look at this.

comment:3 Changed 6 years ago by skyper

Ticket #10390 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by skyper

Cc: richlv added

comment:5 Changed 6 years ago by skyper

Ticket #10515 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by skyper

Cc: DeeHants bastiK added

comment:7 Changed 6 years ago by Don-vip

Milestone: 14.12

comment:8 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7850/josm:

fix #9605, fix #10050 - align nodes in line moves outer instead of inner node (patch by oligo)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.