Ignore:
Timestamp:
2024-02-14T18:11:54+01:00 (4 months ago)
Author:
taylor.smock
Message:

Fix #23355: Sanity check JVM arguments on startup

See #17858: JOSM will no longer continue running if the user is on an unsupported
Java version (for this commit, older than Java 11; message indicates Java 17).
This does update the link for Azul from Java 17 to Java 21 as well.

In order to (hopefully) reduce confusion, the webstart and Java update nags will
also be reset in the event that JOSM will exit due to old Java versions. This is
mostly so that users will get the messages to update to OpenWebstart or the
appropriate Java link for their platform and architecture.

Additionally, this will (hopefully) reduce the number of tickets we have to close
due to missing JVM arguments by informing users of the missing arguments at startup.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/native/linux/tested/DEBIAN/control

    r18889 r18985  
    66Priority: extra
    77Architecture: all
    8 Depends: default-jre (>= 2:1.17) | java8-runtime,
     8Depends: default-jre (>= 2:1.17) | java11-runtime,
    99         proj-data, fonts-noto, openjfx
    1010Conflicts: josm-plugins
Note: See TracChangeset for help on using the changeset viewer.