wiki:DevelopersGuide/CompilingUsingIntelliJ

Compiling using ​IntelliJ IDEA

This describes how to develop and compile JOSM using IntelliJ IDEA

  1. Source code#Getthesource
  2. Run ant in the source directory to obtain a josm-custom.jarSource code#CompilingusingAnt
  3. In IntelliJ: File → New → Project from Existing Sources
    1. Navigate to the JOSM source code
  4. File → Project Structure
    • Modules → Sources: Exclude the directory src/org/apache
    • Modules → Dependencies: Make sure that josm-custom (i.e., the file generated by Ant is listed)
    • Modules → Dependencies: Add Groovy (you might need to configure that at "Global Libraries")
  5. Run → Edit Configuration
    • Add an "Application" configuration

Whenever presets, images, styles, or parser definitions change, re-run Ant in order to have those modifications included in josm-custom.jar.

This is a bit hackish, but works nicely. ☻

Additional settings

This section describes helpful additional settings for IntelliJ IDEA.

Link ticket references in commit messages

→ Ticket references in version control log are clickable

Search open issues

→ Tools → Tasks & Contexts → Open Task

Last modified 16 months ago Last modified on 2016-11-03T22:00:01+01:00

Attachments (10)

Download all attachments as: .zip