Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#7696 closed defect (duplicate)

Error while uploading data

Reported by: art.penteur@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. load the attached Marciac-bug OSM file
  2. update the data (in case something has changed in the OSM base)
  3. try to upload the new data.

What is the expected result?
New adata uploaded in OSM database

What happens instead?
A pop-up window saying that a coding error happened an thta I should file a bug report.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-05-02 01:31:00
Last Changed Author: stoecker
Revision: 5210
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-05-01 16:42:42 +0200 (Tue, 01 May 2012)
Last Changed Rev: 5210

Identification: JOSM/1.5 (5210 fr)
Memory Usage: 100 MB / 247 MB (31 MB allocated, but free)
Java version: 1.6.0_31, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: cadastre-fr (27981)
Plugin: licensechange (27964)
Plugin: openstreetbugs (27852)
Plugin: reverter (28089)
Plugin: turnrestrictions (27891)

org.openstreetmap.josm.io.OsmTransferException: org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.
	at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:497)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesAsDiffUpload(OsmServerWriter.java:132)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:208)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:246)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.ru

Attachments (1)

Marciac-bug.osm (124.5 KB) - added by art.penteur@… 6 years ago.
Some data I can't upload to the base

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by art.penteur@…

Attachment: Marciac-bug.osm added

Some data I can't upload to the base

comment:1 Changed 6 years ago by bastiK

OSM-Server responded something strange, please try again.

comment:2 Changed 6 years ago by bastiK

comment:3 Changed 6 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #6999 .

comment:4 in reply to:  2 Changed 6 years ago by anonymous

Replying to bastiK:

Looks like it uploaded all right: http://www.openstreetmap.org/browse/changeset/11621437

True enough.
Looking at the time, we can see that the changeset was not closed by JOSM, but automatically after the one-hour delay.
So, something went wrong, but this did not prevent the data transfer.
Is this a bug in the protocol, on the server, in JOSM ?
Could the pop-up have been more explicit (something like : "something strange happened in the dialog with the server. Your data seems to have been tranfered OK. You may try to explicitly close the changeset and update the data to check if everything was OK") ?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.