Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2836 closed defect (fixed)

[PATCH]Download of plugins fails on JOSM 1738

Reported by: valent.turkovic@… Owned by: jttt
Priority: blocker Milestone:
Component: Core Version:
Keywords: plugin download Cc: delta_foxtrot@…

Description

Download of plugins fails on JOSM 1738 with this message:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1738
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1738
Last Changed Date: 2009-07-05 19:42:18 +0200 (Sun, 05 Jul 2009)

Memory Usage: 23 MB / 508 MB (8 MB allocated, but free)
Java version: 1.6.0_0

java.lang.NullPointerException

at org.openstreetmap.josm.plugins.PluginSelection.finish(PluginSelection.java:101)
at org.openstreetmap.josm.gui.preferences.PluginPreference.ok(PluginPreference.java:116)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.ok(PreferenceDialog.java:93)
at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:80)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:39)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
at java.awt.Component.processMouseEvent(Component.java:6108)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3276)
at java.awt.Component.processEvent(Component.java:5873)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4469)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
at java.awt.Container.dispatchEventImpl(Container.java:2149)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (1)

plugin.patch (723 bytes) - added by jttt 9 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 9 years ago by stoecker

Owner: changed from team to jttt

comment:2 Changed 9 years ago by stoecker

Ticket #2841 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by stoecker

Ticket #2842 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by stoecker

Ticket #2843 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by stoecker

Ticket #2844 has been marked as a duplicate of this ticket.

comment:6 Changed 9 years ago by delta_foxtrot2

Cc: delta_foxtrot@… added
Priority: majorblocker

comment:7 Changed 9 years ago by delta_foxtrot2

This issue doesn't exist in r1732

comment:8 Changed 9 years ago by stoecker

Report #2841 is about 1669 so r1732 must be affected as well. Probably that issue is network related.

comment:9 Changed 9 years ago by valent.turkovic@…

For me downloading plugins works on 1669, but after a lot of plugins complained how I'm using too old version of JOSM I deleted ~/.josm folder, downloaded 1738 and started it on my Fedora 11 box.

I tried now again and same issue.

comment:10 in reply to:  8 Changed 9 years ago by delta_foxtrot2

Replying to stoecker:

Report #2841 is about 1669 so r1732 must be affected as well. Probably that issue is network related.

I can't comment about #2841, but after r1738 failed to work I downloaded r1732 and it works fine.

comment:11 in reply to:  9 Changed 9 years ago by delta_foxtrot2

Replying to valent.turkovic@…:

For me downloading plugins works on 1669, but after a lot of plugins complained how I'm using too old version of JOSM I deleted ~/.josm folder, downloaded 1738 and started it on my Fedora 11 box.

I had the same issue, and reported this under a different bug ID because wmsplugin for yahoo sat imagery only does hi-res now. If you download r1732 you will be able to download plugins etc.

comment:12 Changed 9 years ago by anonymous

There is at least one stupid bug - line 97 in PluginSelection should be:
Collection<String> installedPlugins = Main.pref.getCollection("plugins", Collections.<String>emptySet());
not
Collection<String> installedPlugins = Main.pref.getCollection("plugins", null);

But this would fail only if there are no plugins installed. No idea yet why it fail in other cases.

comment:13 Changed 9 years ago by valent.turkovic@…

For me downloading plugins with 1732 works.

downloaded from: http://josm.openstreetmap.de/download/

java -jar bin/josm-snapshot-1732.jar

works ok!

comment:14 in reply to:  12 ; Changed 9 years ago by delta_foxtrot2

Replying to anonymous:

But this would fail only if there are no plugins installed. No idea yet why it fail in other cases.

Checking diffs, that code was already in 1732, yet it works...

http://josm.openstreetmap.de/changeset?new=1738%40trunk&old=1732%40trunk

comment:15 in reply to:  14 Changed 9 years ago by delta_foxtrot2

Replying to delta_foxtrot2:

Replying to anonymous:

But this would fail only if there are no plugins installed. No idea yet why it fail in other cases.

Checking diffs, that code was already in 1732, yet it works...

http://josm.openstreetmap.de/changeset?new=1738%40trunk&old=1732%40trunk

Actually it was also added after 1732, but already existed in another location on line 141 or 139

Changed 9 years ago by jttt

Attachment: plugin.patch added

comment:16 Changed 9 years ago by jttt

Summary: Download of plugins fails on JOSM 1738[PATCH]Download of plugins fails on JOSM 1738

No report lists installed plugins so maybe it really enough to make sure installedPlugins is not null.

comment:17 Changed 9 years ago by stoecker

Resolution: fixed
Status: newclosed

In r1739.

comment:18 Changed 9 years ago by anonymous

Ticket #2854 has been marked as a duplicate of this ticket.

comment:19 Changed 9 years ago by stoecker

Ticket #2848 has been marked as a duplicate of this ticket.

comment:20 Changed 9 years ago by delta_foxtrot2

Ticket #2858 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.