Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2843 closed defect (duplicate)

JOSM svn rev 1738 crashes when attempting to download plugins

Reported by: delta_foxtrot2 Owned by: team
Priority: blocker Milestone:
Component: Plugin Version:
Keywords: Cc:

Description

Unable to download plugins with JOSM r1738, it throws up a crash dialog, dumped to stdout...

java.lang.NullPointerException

at org.openstreetmap.josm.plugins.PluginSelection.finish(PluginSelection.java:101)
at org.openstreetmap.josm.gui.preferences.PluginPreference.ok(PluginPreference.java:116)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.ok(PreferenceDialog.java:93)
at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:80)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:39)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
at java.awt.Component.processMouseEvent(Component.java:6216)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
at java.awt.Component.processEvent(Component.java:5981)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4583)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by delta_foxtrot2

Problem doesn't exist in r1732, the .josm directory was removed and still unable to download plugins.

comment:2 Changed 9 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by stoecker

Closed as duplicate of #2836.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.