Modify

Opened 11 days ago

Closed 11 days ago

#15300 closed defect (duplicate)

Scroll page with cursor

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin continuosDownload Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Build-Date:2017-09-02 20:53:16
Revision:12712
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12712 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 989 MB / 989 MB (550 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 3840x2160
Maximum Screen Size: 3840x2160
Program arguments: [D:\Users\<user.name>\Desktop\12.shp_20170910_012353699.osm]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (33160)
+ BuildingGeneralization (1010)
+ Create_grid_of_ways (32699)
+ FastDraw (33583)
+ FixAddresses (33182)
+ HouseNumberTaggingTool (33160)
+ ImproveWay (12)
+ PicLayer (33385)
+ ShapeTools (1220)
+ alignways (33182)
+ apache-commons (33517)
+ auto_tools (1494971731)
+ buildings_tools (33004)
+ continuosDownload (53)
+ contourmerge (1030)
+ dataimport (33581)
+ editgpx (33004)
+ ejml (32680)
+ geotools (33380)
+ imagery_offset_db (33547)
+ importvec (33564)
+ jts (32699)
+ measurement (33088)
+ merge-overlap (33436)
+ opendata (33553)
+ osmarender (33004)
+ pdfimport (33579)
+ photoadjust (33303)
+ reltoolbox (33530)
+ reverter (33572)
+ tageditor (33579)
+ terracer (33579)
+ turnrestrictions (33537)
+ utilsplugin2 (33579)
+ walkingpapers (32796)
+ wikipedia (33541)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.
- E: Handled by bug report queue: java.lang.IllegalStateException: Timer already cancelled.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalStateException: Timer already cancelled.
	at java.util.Timer.sched(Unknown Source)
	at java.util.Timer.schedule(Unknown Source)
	at org.openstreetmap.josm.plugins.continuosDownload.DownloadPlugin.zoomChanged(DownloadPlugin.java:93)
	at org.openstreetmap.josm.gui.NavigatableComponent.fireZoomChanged(NavigatableComponent.java:140)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomNoUndoTo(NavigatableComponent.java:677)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomTo(NavigatableComponent.java:657)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomTo(NavigatableComponent.java:577)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomToFactor(NavigatableComponent.java:741)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomManyTimes(NavigatableComponent.java:733)
	at org.openstreetmap.josm.gui.MapMover.mouseWheelMoved(MapMover.java:248)
	at java.awt.Component.processMouseWheelEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 11 days ago by Don-vip

Component: CorePlugin continuosDownload

comment:2 Changed 11 days ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8836.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.