Modify

Opened 4 years ago

Closed 2 months ago

#8836 closed defect (fixed)

IllegalStateException: Timer already cancelled in continuos download plugin

Reported by: anonymous Owned by: Gnonthgol
Priority: major Milestone:
Component: Plugin continuosDownload Version:
Keywords: github Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. simply following a way track 8 km with low level zoom

What is the expected result?
no bug report and normal ram load

What happens instead?
bug on continuos downlod plugin and high ram consuming

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-06-28 01:34:43
Last Changed Author: akks
Revision: 6037
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-06-27 20:26:18 +0200 (Thu, 27 Jun 2013)
Last Changed Rev: 6037

Identification: JOSM/1.5 (6037 it) Linux Ubuntu 13.04
Memory Usage: 351 MB / 419 MB (238 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugin: AddrInterpolation (29435)
Plugin: FastDraw (29596)
Plugin: ImportImagePlugin (29531)
Plugin: OpeningHoursEditor (29435)
Plugin: PicLayer (29601)
Plugin: SimplifyArea (29435)
Plugin: buildings_tools (29596)
Plugin: continuosDownload (28565)
Plugin: dataimport (29435)
Plugin: download_along (29435)
Plugin: geochat (29592)
Plugin: geotools (29435)
Plugin: irsrectify (29210)
Plugin: jts (29613)
Plugin: log4j (29435)
Plugin: mapdust (29525)
Plugin: mirrored_download (29643)
Plugin: multipoly-convert (29435)
Plugin: namemanager (29435)
Plugin: opendata (29706)
Plugin: openstreetbugs (29435)
Plugin: print (29529)
Plugin: proj4j (29435)
Plugin: reverter (29663)
Plugin: scripting (30540)
Plugin: tageditor (29435)
Plugin: tagging-preset-tester (29435)
Plugin: terracer (29623)
Plugin: turnrestrictions (29435)
Plugin: undelete (29555)
Plugin: utilsplugin2 (29672)
Plugin: walkingpapers (29480)
Plugin: waydownloader (29435)
Plugin: wayselector (29435)
Plugin: wikipedia (29523)

java.lang.IllegalStateException: Timer already cancelled.
	at java.util.Timer.sched(Timer.java:397)
	at java.util.Timer.schedule(Timer.java:193)
	at org.openstreetmap.josm.plugins.continuosDownload.DownloadPlugin.zoomChanged(DownloadPlugin.java:87)
	at org.openstreetmap.josm.gui.NavigatableComponent.fireZoomChanged(NavigatableComponent.java:128)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomNoUndoTo(NavigatableComponent.java:413)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomTo(NavigatableComponent.java:391)
	at org.openstreetmap.josm.gui.NavigatableComponent.zoomTo(NavigatableComponent.java:417)
	at org.openstreetmap.josm.gui.MapMover.mouseDragged(MapMover.java:130)
	at java.awt.AWTEventMulticaster.mouseDragged(AWTEventMulticaster.java:320)
	at java.awt.AWTEventMulticaster.mouseDragged(AWTEventMulticaster.java:319)
	at java.awt.Component.processMouseMotionEvent(Component.java:6553)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3339)
	at java.awt.Component.processEvent(Component.java:6274)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4509)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (15)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin continuousDownload
Owner: changed from team to Gnonthgol

comment:2 Changed 4 years ago by Don-vip

Description: modified (diff)
Summary: continuos downloadIllegalStateException: Timer already cancelled in continuos download plugin

comment:3 Changed 4 years ago by Don-vip

Keywords: github added; template_report removed

comment:4 Changed 4 years ago by Don-vip

Ticket #9170 has been marked as a duplicate of this ticket.

comment:5 Changed 4 years ago by Don-vip

Resolution: othersoftware
Status: newclosed

Closing tickets for external Github-hosted plugins as "othersoftware". Bug report is done on Github, see above.

comment:6 Changed 4 years ago by Don-vip

Ticket #9980 has been marked as a duplicate of this ticket.

comment:7 Changed 3 years ago by Don-vip

Ticket #10189 has been marked as a duplicate of this ticket.

comment:8 Changed 3 years ago by Don-vip

Ticket #10577 has been marked as a duplicate of this ticket.

comment:9 Changed 5 months ago by Don-vip

Ticket #14942 has been marked as a duplicate of this ticket.

comment:10 Changed 5 months ago by Don-vip

Priority: normalmajor

comment:11 Changed 2 months ago by Don-vip

Ticket #15300 has been marked as a duplicate of this ticket.

comment:12 Changed 2 months ago by Don-vip

Resolution: othersoftware
Status: closedreopened

comment:13 Changed 2 months ago by Don-vip

Ticket #15317 has been marked as a duplicate of this ticket.

comment:14 Changed 2 months ago by Don-vip

comment:15 Changed 2 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gnonthgol.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.