Modify

Opened 11 months ago

Closed 3 months ago

#13631 closed defect (fixed)

IAE: Listener CommandLine.(XXX)Action was not registered before or already removed

Reported by: mcheck Owned by: Hind
Priority: critical Milestone:
Component: Plugin commandline Version:
Keywords: template_report regression gsoc-core Cc: michael2402, luiswoo, Stereo, RiGs

Description

What steps will reproduce the problem?

  1. select a poly and then use the cut command from commandLine plugin

What is the expected result?

What happens instead?

crash

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-12 21:15:56 +0200 (Mon, 12 Sep 2016)
Build-Date:2016-09-13 01:34:47
Revision:10996
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10996 it) Linux Ubuntu 16.04.1 LTS
Memory Usage: 443 MB / 910 MB (119 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (32699)
+ BuildingGeneralization (1010)
+ CommandLine (32796)
+ DirectDownload (32699)
+ FastDraw (32938)
+ FixAddresses (32796)
+ ImportImagePlugin (32699)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ SimplifyArea (32796)
+ apache-commons (32699)
+ buildings_tools (32944)
+ continuosDownload (53)
+ contourmerge (1022)
+ dataimport (32699)
+ download_along (32946)
+ ejml (32680)
+ geotools (32813)
+ importvec (32699)
+ jts (32699)
+ log4j (32699)
+ namemanager (32699)
+ opendata (32898)
+ pbf (32865)
+ pdfimport (32796)
+ photoadjust (32863)
+ print (32965)
+ reverter (32796)
+ scripting (30730)
+ tagging-preset-tester (32869)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ ${HOME}/josm_styles/mb_building_evi.mapcss

Last errors/warnings:
- W: java.net.SocketException: Socket closed
- E: java.net.SocketException: Socket closed
- W: java.net.SocketException: Socket closed
- E: java.net.SocketException: Socket closed
- W: java.net.SocketException: Socket closed
- E: java.net.SocketException: Socket closed
- W: Unable to use English input method
- W: java.net.SocketException: Socket closed
- E: java.net.SocketException: Socket closed
- W: org.openstreetmap.josm.io.IllegalDataException: Linea 1 colonna 1: Fine del file anticipata.. Causa: org.xml.sax.SAXParseException: Fine del file anticipata.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Listener CommandLine.NodeAction@5698dcf0 (instance of CommandLine.NodeAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:129)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:206)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:123)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:190)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:238)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:78)
	at CommandLine.NodeAction.exitMode(NodeAction.java:52)
	at CommandLine.NodeAction.mousePressed(NodeAction.java:93)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280)
	at java.awt.Component.processMouseEvent(Component.java:6530)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4522)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (26)

comment:1 Changed 11 months ago by Don-vip

Cc: michael2402 added
Keywords: regression gsoc-core added

comment:2 Changed 11 months ago by michael2402

An exitMode bug (again) => CommandLine.NodeAction.mousePressed(NodeAction.java:93) may not call exitMode.

comment:3 Changed 11 months ago by Don-vip

can you please commit the fix directly? :)

comment:4 Changed 11 months ago by Don-vip

Summary: crash using cut commandIAE: Listener CommandLine.(XXX)Action was not registered before or already removed

comment:5 Changed 11 months ago by Don-vip

Ticket #13657 has been marked as a duplicate of this ticket.

comment:6 Changed 11 months ago by Don-vip

Ticket #13695 has been marked as a duplicate of this ticket.

comment:7 Changed 11 months ago by Klumbumbus

Ticket #13685 has been marked as a duplicate of this ticket.

comment:8 Changed 11 months ago by Klumbumbus

Ticket #13728 has been marked as a duplicate of this ticket.

comment:9 Changed 10 months ago by Klumbumbus

Ticket #13874 has been marked as a duplicate of this ticket.

comment:10 Changed 9 months ago by skyper

Ticket #13935 has been marked as a duplicate of this ticket.

comment:11 Changed 9 months ago by skyper

Cc: luiswoo added
Priority: normalmajor

comment:12 Changed 7 months ago by Don-vip

Ticket #14107 has been marked as a duplicate of this ticket.

comment:13 Changed 7 months ago by Don-vip

Priority: majorcritical

comment:14 Changed 7 months ago by Stereo

Ticket #14320 has been marked as a duplicate of this ticket.

comment:15 Changed 7 months ago by Stereo

Cc: Stereo added

comment:16 Changed 6 months ago by RiGs

Cc: RiGs added

comment:17 Changed 6 months ago by RiGs

comment:18 Changed 5 months ago by Stereo

michael2402 do you know how to fix this?

comment:19 Changed 4 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33239:33240].

comment:20 Changed 4 months ago by Don-vip

Ticket #14727 has been marked as a duplicate of this ticket.

comment:21 Changed 4 months ago by Klumbumbus

Ticket #14731 has been marked as a duplicate of this ticket.

comment:22 Changed 4 months ago by Klumbumbus

Resolution: fixed
Status: closedreopened

Not fully fixed. #14731 is with version 33239

comment:23 Changed 3 months ago by Don-vip

Ticket #14897 has been marked as a duplicate of this ticket.

comment:24 Changed 3 months ago by istepan

Resolution: fixed
Status: reopenedclosed

Fixed: Path

Ticket path: #14903

Last edited 3 months ago by istepan (previous) (diff)

comment:25 Changed 3 months ago by istepan

Resolution: fixed
Status: closedreopened

Pls apply my path.

comment:26 Changed 3 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Fixed in [o33368:33369]. Thanks! :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Hind.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.