Modify

#13695 closed defect (duplicate)

commandline cut element error

Reported by: mcheck Owned by: Hind
Priority: normal Milestone:
Component: Plugin commandline Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. select a close poly way ele and then use try to use the cut command

What is the expected result?

working

What happens instead?

error report request

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 it) Linux Ubuntu 16.04.1 LTS
Memory Usage: 447 MB / 910 MB (180 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (32699)
+ BuildingGeneralization (1010)
+ CommandLine (32796)
+ DirectDownload (32699)
+ FastDraw (32938)
+ FixAddresses (32796)
+ ImportImagePlugin (32699)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ SimplifyArea (32796)
+ apache-commons (32699)
+ buildings_tools (32944)
+ continuosDownload (53)
+ contourmerge (1022)
+ dataimport (32699)
+ download_along (32946)
+ ejml (32680)
+ geotools (32813)
+ importvec (32699)
+ jts (32699)
+ log4j (32699)
+ namemanager (32699)
+ opendata (32898)
+ pbf (32865)
+ pdfimport (32796)
+ photoadjust (32863)
+ print
+ reverter (32796)
+ scripting (30730)
+ tagging-preset-tester (32869)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ ${HOME}/josm_styles/mb_building_evi.mapcss
- ${HOME}/src/JOSM-Orphan-nodes-map-paint-style/orphan_nodes.mapcss

Last errors/warnings:
- W: Attenzione - <html>L'estensione print richiede la versione 10972 di JOSM. La versione corrente di JOSM è la 10966.<br>Si deve aggiornare JOSM per utilizzare questa estensione.</html>
- W: org.openstreetmap.josm.io.IllegalDataException: Linea 1 colonna 1: Fine del file anticipata.. Causa: org.xml.sax.SAXParseException: Fine del file anticipata.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Listener CommandLine.WayAction@1d691548 (instance of CommandLine.WayAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:129)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:206)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:123)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:190)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:238)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:78)
	at CommandLine.WayAction.exitMode(WayAction.java:73)
	at CommandLine.WayAction.mousePressed(WayAction.java:114)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280)
	at java.awt.Component.processMouseEvent(Component.java:6530)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4522)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 15 months ago by Don-vip

Component: CorePlugin commandline
Owner: changed from team to Hind

comment:2 Changed 15 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13631.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Hind.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.