Modify

Opened 7 years ago

Closed 7 years ago

#9986 closed defect (duplicate)

Resolving export conflicts

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Resolv export conflicts

What is the expected result?
Corretion of conflict

What happens instead?
bug report

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-06 01:36:32
Last Changed Author: Don-vip
Revision: 7068
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-06 01:24:41 +0200 (Tue, 06 May 2014)
Last Changed Rev: 7068

Identification: JOSM/1.5 (7068 it) Linux Ubuntu 12.04.4 LTS
Memory Usage: 521 MB / 931 MB (271 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-1ubuntu1~0.12.04.2
VM arguments: [-Xmx1048m]

Dataset consistency test:
[DELETED REFERENCED] {Way id=252268292 version=2 MVT nodes=[{Node id=2656829701 version=1 V lat=45.143013,lon=7.5870329}, {Node id=2656829706 version=1 V lat=45.1416188,lon=7.5915694}, {Node id=2656829710 version=1 V lat=45.1408265,lon=7.5941472}, {Node id=2656829714 version=1 V lat=45.1394154,lon=7.5987386}, {Node id=742658106 version=1 V lat=45.1392739,lon=7.5991988}, {Node id=742658088 version=1 V lat=45.1384217,lon=7.6021075}, {Node id=742658096 version=1 V lat=45.1382139,lon=7.6027482}, {Node id=742658090 version=1 V lat=45.1383005,lon=7.6038564}, {Node id=2656829636 version=1 V lat=45.1395803,lon=7.6062605}, {Node id=1286538577 version=2 VD lat=45.1401343,lon=7.6072128}, {Node id=2656829726 version=1 V lat=45.1417437,lon=7.6101301}, {Node id=1679659581 version=1 V lat=45.141792,lon=7.6102177}]} refers to deleted primitive {Node id=1286538577 version=2 VD lat=45.1401343,lon=7.6072128}


Plugin: AddrInterpolation (30416)
Plugin: CommandLine (30416)
Plugin: FastDraw (30416)
Plugin: FixAddresses (30416)
Plugin: HouseNumberTaggingTool (30416)
Plugin: ImportImagePlugin (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: PicLayer (30416)
Plugin: RoadSigns (30416)
Plugin: SimplifyArea (30416)
Plugin: alignways (30416)
Plugin: buildings_tools (30416)
Plugin: continuosDownload (28565)
Plugin: contourmerge (1010)
Plugin: dataimport (30416)
Plugin: download_along (30416)
Plugin: ext_tools (30416)
Plugin: geotools (30416)
Plugin: imagery_offset_db (30416)
Plugin: imageryadjust (30416)
Plugin: importvec (30416)
Plugin: irsrectify (29210)
Plugin: jts (30416)
Plugin: junctionchecking (30416)
Plugin: lakewalker (30416)
Plugin: log4j (30416)
Plugin: mirrored_download (30416)
Plugin: namemanager (30416)
Plugin: notes (v0.9.2)
Plugin: opendata (30416)
Plugin: pbf (30416)
Plugin: pdfimport (30416)
Plugin: plastic_laf (30416)
Plugin: poly (30416)
Plugin: print (30416)
Plugin: proj4j (30417)
Plugin: reltoolbox (30416)
Plugin: reverter (30416)
Plugin: scripting (30603)
Plugin: tag2link (30416)
Plugin: tageditor (30416)
Plugin: tagging-preset-tester (30416)
Plugin: terracer (30416)
Plugin: turnlanes (30416)
Plugin: turnrestrictions (30416)
Plugin: utilsplugin2 (30419)
Plugin: walkingpapers (30416)
Plugin: wikipedia (30416)
Plugin: wms-turbo-challenge2 (30416)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=252268292 version=2 MVT nodes=[{Node id=2656829701 version=1 V lat=45.143013,lon=7.5870329}, {Node id=2656829706 version=1 V lat=45.1416188,lon=7.5915694}, {Node id=2656829710 version=1 V lat=45.1408265,lon=7.5941472}, {Node id=2656829714 version=1 V lat=45.1394154,lon=7.5987386}, {Node id=742658106 version=1 V lat=45.1392739,lon=7.5991988}, {Node id=742658088 version=1 V lat=45.1384217,lon=7.6021075}, {Node id=742658096 version=1 V lat=45.1382139,lon=7.6027482}, {Node id=742658090 version=1 V lat=45.1383005,lon=7.6038564}, {Node id=2656829636 version=1 V lat=45.1395803,lon=7.6062605}, {Node id=1286538577 version=2 VD lat=45.1401343,lon=7.6072128}, {Node id=2656829726 version=1 V lat=45.1417437,lon=7.6101301}, {Node id=1679659581 version=1 V lat=45.141792,lon=7.6102177}]}
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:592)
	at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:608)
	at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:73)
	at org.openstreetmap.josm.data.osm.DataSet.unlinkNodeFromWays(DataSet.java:832)
	at org.openstreetmap.josm.data.osm.DataSet.unlinkReferencesToPrimitive(DataSet.java:888)
	at org.openstreetmap.josm.command.conflict.DeletedStateConflictResolveCommand.deleteMy(DeletedStateConflictResolveCommand.java:75)
	at org.openstreetmap.josm.command.conflict.DeletedStateConflictResolveCommand.executeCommand(DeletedStateConflictResolveCommand.java:58)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:52)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:43)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:69)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog$ApplyResolutionAction.actionPerformed(ConflictResolutionDialog.java:215)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3311)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
...<snip>...

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #6529.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.