Modify

Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#9883 closed defect (duplicate)

Unable to load Java Runtime Environment on Mac OS 10.9 after upgrading to 6950

Reported by: Alexander Kachkaev <alexander@…> Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: bug, jre, bootstrap, 6950 Cc:

Description

It's strange, but after downloading JOSM 6950 and replacing the old JOSM.app in /Applications directory, I can't open the programme any more.

The error I get says "Unable to load Java Runtime Environment".

Reverting the app to JOSM 6891 using time machine makes everything working fine again.

I could be that I have a relatively rare java path config (otherwise the bug would have been already spotted), but even if so, such change of behaviour feels very suspicious.

I am ready provide further details for investigation if the reason for the problem is not instantly obvious.

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8654.
It's not strange, we have changed the packaging to use Oracle Java 7 instead of Apple Java 6.

You must install Java 7 to use the package. If you can't, JOSM is still usable with Apple Java 6 via WebStart or manual launch (java -jar josm-tested.jar).

Please note the next tested version at the end of April will be the last supporting Java 6. So starting from May, installing Java 7 will be mandatory.

comment:2 Changed 7 years ago by Alexander Kachkaev <alexander@…>

Thanks for clarifying this!

I guess it would be beneficial to other users if there was a corresponding warning message on a welcome page of any old JOSM for those with JRE 6. E.g. "You should update! (make sure you have Java Runtime Environment 7 before opening the new JOSM)"

A similar comment near "Mac OS X package (version 6950)" would be also useful.

The message about the upcoming migration to JRE 7 was there for ages, and I guess many people started to ignore it. AFAK OSX is still supplied with JRE 6 by default.

comment:3 in reply to:  2 ; Changed 7 years ago by Don-vip

Replying to Alexander Kachkaev:

I guess it would be beneficial to other users if there was a corresponding warning message on a welcome page of any old JOSM for those with JRE 6. E.g. "You should update! (make sure you have Java Runtime Environment 7 before opening the new JOSM)"

It is already the case in startup notes for several months now, and it helped a lot to increase Java 7 usage among our users. There's also a more intrusive warning if you start JOSM >= 6950 with Java 6. Can you tell me if it's correctly displayed? See #9879 for a screenshot of it.

A similar comment near "Mac OS X package (version 6950)" would be also useful.

Yep, I forgot to add it. Done.

comment:4 in reply to:  2 Changed 7 years ago by stoecker

Replying to Alexander Kachkaev:

The message about the upcoming migration to JRE 7 was there for ages, and I guess many people started to ignore it. AFAK OSX is still supplied with JRE 6 by default.

"We mean it".
"Really".
"You can believe it"

Something like this?

comment:5 in reply to:  3 Changed 7 years ago by Alexander Kachkaev <alexander@…>

There's also a more intrusive warning if you start JOSM >= 6950 with Java 6. Can you tell me if it's correctly displayed? See #9879 for a screenshot of it.

If you mean this one: http://josm.openstreetmap.de/attachment/ticket/9879/Veraltete%20Java-Version_055.jpeg, nope, I don't see it. The only message that come out says Unable to load Java Runtime Environment — that's it. I could not instantly figure out why JOSM was not launching and re-downloaded the archive a few times before realising that I got stuck and restored the old JOSM using Time Machine :-) But with a comment you've added near the download link, the cause of the problem in a similar case will be more or less obvious.

Cheers!

comment:6 Changed 7 years ago by Alexander Kachkaev <alexander@…>

I guess that the title of the home page should be changed accordingly. "JOSM is an extensible editor for ​OpenStreetMap (OSM) written in ​Java 6." – that what it says now. There are some more occurrences of "Java 6" across the website: https://www.google.com/search?q=%22java%206%22%20site%3Ajosm.openstreetmap.de%20-inurl%3Aticket%20-inurl%3Asrc%20-inurl%3Achangeset

comment:7 Changed 7 years ago by stoecker

JOSM will switch to Java 7 in May. It's not yet done. It still runs with Java 6. See #8465.

comment:8 Changed 7 years ago by Don-vip

You don't see the message because the osx package does only work with java 7. Any other way to launch josm (webstart or jar) should trigger the popup with java 6.

Last edited 7 years ago by Don-vip (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.