Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9725 closed enhancement (fixed)

Validator reports unknown "relation type" for valid route types

Reported by: mdk Owned by: team
Priority: normal Milestone: 14.02
Component: Internal preset Version: latest
Keywords: route Cc:

Description

The Validator reports relations of type=route or route=train (see relation 3185768) and route=bus (see relation 103190) as "Relations type is unknown".

But route=railway and route=road cause no warning.

On the other hand I was a little bit confused by the warning message itself. When the "Relation type" is unknown I first look at the type=<type> tag of the relation. But the problem is not this tag, but the <type>=* tag. In this case the route=* tags. Perhaps "Route type is unknown" is a better warning depending on the relation type.

Attachments (0)

Change History (5)

comment:1 by mdk, 10 years ago

Component: CoreCore validator
Summary: Validator reports unknown relations typesValidator reports unknown "relation type" for valid route types
Version: latest

comment:2 by Don-vip, 10 years ago

Component: Core validatorInternal preset
Keywords: route added
Milestone: 14.02

comment:3 by Don-vip, 10 years ago

Type: defectenhancement

comment:4 by simon04, 10 years ago

Resolution: fixed
Status: newclosed

In 6863/josm:

see #9545 fix #9725 - Validator: add warning "Route scheme (public_transport or legacy) is unspecified"

comment:5 by Zverikk, 10 years ago

Has this tag passed proposal stage on OSM wiki? Why it is suddenly required?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.