Modify

Opened 8 years ago

Closed 5 years ago

#9697 closed defect (invalid)

inconsistent layer merging behaviour

Reported by: richlv Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: merging Cc:

Description

open 3 gpx files. select one of them, choose "merge layer into another layer" - notice how two remaining layers are available in the dropdown list. select two, choose "merge layer into another layer" - notice how only the selected layers are available in the dropdown list. instead, the remaining layer should be the only one there.

additionally, when merging layers, it would seem intuitive if the dropdown would default to the layer just below the selected layer - instead it seems to default to the first possible layer from the list.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Don-vip

Resolution: invalid
Status: newclosed

I agree it's not very intuitive, but that's the intended behaviour. It is not possible to merge several layers into one, it's only on a 1-by-1 operation. So when two layers are selected, JOSM asks which layer you want to merge in the other one.

It should probably be documented on the wiki if not already.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.