Modify

Opened 11 years ago

Closed 11 years ago

#968 closed defect (wontfix)

Unreadable view of downloaded gps tracks if lines are turned on

Reported by: osm@… Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

  1. Download Raw GPS data from bbox

min lat: 49.036892 min lon: 22.466505
max lat: 49.124784 max lon: 22.642288

  1. Turn on option Draw lines between raw gps points in Display Settings (if it was not turned on yet)
  1. See what happens.

Version 622.

Attachments (4)

gkrellShoot_06-28-08_111210.jpg (103.1 KB) - added by osm@… 11 years ago.
With lines, bad
mixed_small.gpx (22.5 KB) - added by Jan Górski <osm@…> 11 years ago.
Trace created by JOSM from traces downloaded from DB
115867.gpx (20.8 KB) - added by Jan Górski <osm@…> 11 years ago.
Trace by Adrian Siemieniak (cropped)
129345.gpx (28.5 KB) - added by Jan Górski <osm@…> 11 years ago.
Trace by Jan Górski (cropped)

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by osm@…

With lines, bad

comment:1 Changed 11 years ago by anonymous

Resolution: invalid
Status: newclosed

This is actually an error in your data. Your data has a normal track and inbetween jumps back to another position continously. Thus you get such a mixed up display. Either your GPS or the data conversion has a problem.

I had equal problems with an Destinator system which always jumped to a zero longitude.

comment:2 Changed 11 years ago by Jan Górski <osm@…>

Resolution: invalid
Status: closedreopened

Nope. That is not the case. There are two correct tracks inside. To me it looks like JOSM drawing lines between points of those two tracks jumping from one to the other and back.

comment:3 Changed 11 years ago by Jan Górski <osm@…>

I can be seen better on smaller area:
min lat: 49.07126219206578 min lon: 22.53708186101964
max lat: 49.0758309193756 max lon: 22.54398693436374

comment:4 Changed 11 years ago by stoecker

Please add the data file.

comment:5 Changed 11 years ago by Jan Górski <osm@…>

There are two tracks in database:

http://www.openstreetmap.org/user/Adrian%20Siemieniak/traces/115867

http://www.openstreetmap.org/user/Jan%20G%C3%B3rski/traces/129345

I will attach both traces from database and a gpx file made by JOSM for small bounding box (one mentioned on 07/05/08 23:25:25

comment:6 Changed 11 years ago by Jan Górski <osm@…>

Ooops. Traces are to big to be attached. So I will attach only mixed one...

Changed 11 years ago by Jan Górski <osm@…>

Attachment: mixed_small.gpx added

Trace created by JOSM from traces downloaded from DB

Changed 11 years ago by Jan Górski <osm@…>

Attachment: 115867.gpx added

Trace by Adrian Siemieniak (cropped)

Changed 11 years ago by Jan Górski <osm@…>

Attachment: 129345.gpx added

Trace by Jan Górski (cropped)

comment:7 Changed 11 years ago by Jan Górski <osm@…>

I have cropped traces from DB so they fit here.

comment:8 Changed 11 years ago by anonymous

Ok. Can reproduce it now.

Speculating a bit: The two tracks have overlapping time. Maybe they get mixed one into the other.

Here the OSM-Link for better access (easier to copy :-)
http://www.openstreetmap.org/index.html?mlat=49.0824362952273&mlon=22.540768844942093&zoom=11

Same happens for merkaartor editor.

Please could you rereport this issue in the main OSM bug tracker and refer to that bug report here. I fear that is an API bug and not an application bug.

comment:9 Changed 11 years ago by Jan Górski <osm@…>

comment:10 Changed 11 years ago by Jan Górski <osm@…>

Resolution: wontfix
Status: reopenedclosed

This is wontfix by API. API guarantees that points returned will be in an order, but does not guarantee the kind of order. In this case it seems that points of two traces are sorted by time, an that is reason of bad look. The only solution on JOSM side seems to be draw.rawgps.max-line-length

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.