Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9647 closed defect (fixed)

IllegalDataException: An invalid XML character

Reported by: naoliv Owned by: Don-vip
Priority: major Milestone: 14.02
Component: Core Version:
Keywords: Cc:

Description

Trying to see the history of this object http://www.openstreetmap.org/node/415524175 I am seeing this error:

Failed to download data. Its format is either unsupported, ill-formed, and/or inconsistent.

Details (untranslated): An invalid XML character (Unicode: 0x{2}) was found in the value of attribute "{1}" and element is "3".

In console:

INFO: GET http://api.openstreetmap.org/api/0.6/map?bbox=-46.7642123,-1.0579801,-46.762796,-1.0568163
INFO: GET http://api.openstreetmap.org/api/0.6/node/415524175/history
INFO: GET http://api.openstreetmap.org/api/0.6/changesets?changesets=17555094,1424555,1418012
ERROR: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.io.IllegalDataException: An invalid XML character (Unicode: 0x{2}) was found in the value of attribute "{1}" and element is "3".. Cause: org.openstreetmap.josm.io.IllegalDataException: An invalid XML character (Unicode: 0x{2}) was found in the value of attribute "{1}" and element is "3".. Cause: org.xml.sax.SAXParseException: An invalid XML character (Unicode: 0x{2}) was found in the value of attribute "{1}" and element is "3".
org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.io.IllegalDataException: An invalid XML character (Unicode: 0x{2}) was found in the value of attribute "{1}" and element is "3".
	at org.openstreetmap.josm.io.OsmServerChangesetReader.queryChangesets(OsmServerChangesetReader.java:70)
	at org.openstreetmap.josm.gui.history.HistoryLoadTask.realRun(HistoryLoadTask.java:208)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:150)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:744)
Caused by: org.openstreetmap.josm.io.IllegalDataException: An invalid XML character (Unicode: 0x{2}) was found in the value of attribute "{1}" and element is "3".
	at org.openstreetmap.josm.io.OsmChangesetParser.parse(OsmChangesetParser.java:223)
	at org.openstreetmap.josm.io.OsmServerChangesetReader.queryChangesets(OsmServerChangesetReader.java:65)
	... 8 more
Caused by: org.xml.sax.SAXParseException; lineNumber: 9; columnNumber: 56; An invalid XML character (Unicode: 0x{2}) was found in the value of attribute "{1}" and element is "3".
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:198)
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:177)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:441)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:368)
	at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1436)
	at com.sun.org.apache.xerces.internal.impl.XMLScanner.scanAttributeValue(XMLScanner.java:989)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanAttribute(XMLDocumentFragmentScannerImpl.java:1554)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:1326)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2778)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:606)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:848)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:777)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:649)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(SAXParserImpl.java:333)
	at org.openstreetmap.josm.io.OsmChangesetParser.parse(OsmChangesetParser.java:218)
	... 9 more

JOSM is:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-01-30 08:32:58
Last Changed Author: Don-vip
Revision: 6784
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-01-30 09:28:46 +0100 (Thu, 30 Jan 2014)
Last Changed Rev: 6784

Identification: JOSM/1.5 (6784 en) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 247 MB / 4029 MB (107 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u51-2.4.4-1
VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on, -Xms256M, -Xmx4g, -XX:+UseConcMarkSweepGC, -XX:+UseCompressedOops]
Dataset consistency test: No problems found

Plugin: AddrInterpolation (30034)
Plugin: Create_grid_of_ways (29854)
Plugin: FixAddresses (29971)
Plugin: ImageryCache (30135)
Plugin: OpeningHoursEditor (30117)
Plugin: PicLayer (29854)
Plugin: SimplifyArea (30145)
Plugin: buildings_tools (30057)
Plugin: editgpx (29854)
Plugin: geotools (30147)
Plugin: jts (29854)
Plugin: merge-overlap (30034)
Plugin: notes (v0.8)
Plugin: opendata (30213)
Plugin: pdfimport (29913)
Plugin: poly (29854)
Plugin: reverter (30031)
Plugin: tagging-preset-tester (30220)
Plugin: todo (29155)
Plugin: turnrestrictions (30237)
Plugin: undelete (30207)
Plugin: utilsplugin2 (30200)

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by Don-vip

Looks like this changeset:
http://www.openstreetmap.org/changeset/1424555

created by Potlatch 1.0, contains very exotic characters.

comment:2 Changed 8 years ago by Don-vip

Concerning the strange error message badly formatted, I have narrowed it to a bug of Xerces-J that was fixed 10 years ago but apparently not included in Java XML implementation (shame on you, Sun/Oracle):

https://issues.apache.org/jira/browse/XERCESJ-625

comment:3 Changed 8 years ago by Don-vip

I have updated long-standing bug in OSM API:
https://trac.openstreetmap.org/ticket/4382

I doubt it will result in anything as nobody there seems to be fixing bugs, but still...

comment:4 Changed 8 years ago by stoecker

Additional question: The error message looks as if the {.} aren't expanded. Already answered.

Last edited 8 years ago by stoecker (previous) (diff)

comment:5 Changed 8 years ago by Don-vip

Milestone: 14.02
Owner: changed from team to Don-vip
Status: newassigned

comment:6 Changed 8 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 6787/josm:

fix #9647 - filter invalid XML characters in changeset API responses

comment:7 Changed 8 years ago by Don-vip

Fix was easy thanks to bastiK who already did the job :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.