Modify

Opened 5 years ago

Closed 5 years ago

#9639 closed defect (fixed)

NPE when trying to upload data

Reported by: meppen7 Owned by: team
Priority: blocker Milestone: 14.02
Component: Core Version: latest
Keywords: Upload Data Cc: simon04

Description (last modified by rickmastfan67)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-01-30 08:32:58
Last Changed Author: Don-vip
Revision: 6784
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-01-30 09:28:46 +0100 (Thu, 30 Jan 2014)
Last Changed Rev: 6784

Identification: JOSM/1.5 (6784 de) Linux openSUSE 13.1 (Bottle) (x86_64)
Memory Usage: 365 MB / 835 MB (98 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugin: AddrInterpolation (30034)
Plugin: ColumbusCSV (29854)
Plugin: CommandLine (30203)
Plugin: Create_grid_of_ways (29854)
Plugin: FastDraw (29854)
Plugin: FixAddresses (29971)
Plugin: HouseNumberTaggingTool (30172)
Plugin: ImportImagePlugin (29854)
Plugin: InfoMode (29854)
Plugin: OpeningHoursEditor (30117)
Plugin: PicLayer (29854)
Plugin: RoadSigns (30034)
Plugin: SeaMapEditor (29934)
Plugin: SimplifyArea (30145)
Plugin: TombPlugin (44)
Plugin: Tracer2 (30077)
Plugin: alignways (29854)
Plugin: buildings_tools (30057)
Plugin: conflation (0.1.6)
Plugin: contourmerge (1010)
Plugin: dataimport (29854)
Plugin: download_along (30017)
Plugin: editgpx (29854)
Plugin: fieldpapers (b49dadd)
Plugin: geochat (30234)
Plugin: geotools (30147)
Plugin: gpsblam (29832)
Plugin: gpxfilter (29854)
Plugin: graphview (30145)
Plugin: imagery_offset_db (30218)
Plugin: imageryadjust (29854)
Plugin: jts (29854)
Plugin: junctionchecking (30205)
Plugin: livegps (30234)
Plugin: log4j (29853)
Plugin: mapdust (29854)
Plugin: mbtiles (v1.1)
Plugin: measurement (30104)
Plugin: merge-overlap (30034)
Plugin: michigan_left (29854)
Plugin: mirrored_download (30162)
Plugin: namemanager (29930)
Plugin: native_password_manager (29832)
Plugin: notes (v0.8)
Plugin: opendata (30213)
Plugin: openstreetbugs (30004)
Plugin: openvisible (29854)
Plugin: pbf (29854)
Plugin: photo_geotagging (30110)
Plugin: print (30173)
Plugin: proj4j (29854)
Plugin: public_transport (29862)
Plugin: reltoolbox (30209)
Plugin: reverter (30031)
Plugin: routing (30145)
Plugin: scripting (30560)
Plugin: surveyor (30145)
Plugin: tageditor (30110)
Plugin: turnlanes (30043)
Plugin: turnrestrictions (30237)
Plugin: undelete (30207)
Plugin: utilsplugin2 (30200)
Plugin: videomapping (29854)
Plugin: walkingpapers (29854)
Plugin: waydownloader (29908)
Plugin: wikipedia (30125)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.validation.tests.TagChecker.check(TagChecker.java:360)
	at org.openstreetmap.josm.data.validation.Test$TagTest.visit(Test.java:123)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:213)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:200)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.visit(TagChecker.java:464)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:60)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:199)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:222)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:279)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3311)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (12)

comment:1 Changed 5 years ago by rickmastfan67

Description: modified (diff)
Priority: criticalblocker

Got this in Windows 7 as well. Also upgrading this to blocker since it blocks any attempt to upload data if you've added a tag to any way (doesn't show up if all you've done is move some nodes without adding/removing any from a way).

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-01-30 02:37:19
Last Changed Author: Don-vip
Revision: 6783
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-01-30 02:08:22 +0100 (Thu, 30 Jan 2014)
Last Changed Rev: 6783

Identification: JOSM/1.5 (6783 en) Windows 7 64-Bit
Memory Usage: 222 MB / 1820 MB (95 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx2048M]
Dataset consistency test: No problems found

Plugin: ImageryCache (30135)
Plugin: OpeningHoursEditor (30117)
Plugin: buildings_tools (30057)
Plugin: measurement (30104)
Plugin: mirrored_download (30162)
Plugin: notes (v0.8)
Plugin: osmarender (29854)
Plugin: reverter (30031)
Plugin: turnrestrictions (30237)
Plugin: undelete (30207)
Plugin: utilsplugin2 (30200)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.validation.tests.TagChecker.check(TagChecker.java:360)
	at org.openstreetmap.josm.data.validation.Test$TagTest.visit(Test.java:123)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:213)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:200)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.visit(TagChecker.java:464)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:60)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:199)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:222)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:279)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:2 Changed 5 years ago by rickmastfan67

Ticket #9641 has been marked as a duplicate of this ticket.

comment:3 Changed 5 years ago by rickmastfan67

Ticket #9640 has been marked as a duplicate of this ticket.

comment:4 Changed 5 years ago by rickmastfan67

Ticket #9642 has been marked as a duplicate of this ticket.

comment:5 Changed 5 years ago by rickmastfan67

Cc: simon04 added

If I was a betting man, I think [6779] is the cause for this NPE.

comment:6 Changed 5 years ago by rickmastfan67

Summary: Error message when trying upload dataNPE when trying upload data

comment:7 Changed 5 years ago by rickmastfan67

Summary: NPE when trying upload dataNPE when trying to upload data

comment:8 Changed 5 years ago by Lesath

Ticket #9648 has been marked as a duplicate of this ticket.

comment:9 Changed 5 years ago by akks

Resolution: fixed
Status: newclosed

In 6786/josm:

fix #9639: NPE when trying to upload data
(rough fix, needs checking) + fix Netbeans project

comment:10 Changed 5 years ago by akks

Resolution: fixed
Status: closedreopened

Please check the solution logic, then close the ticket.

comment:11 Changed 5 years ago by Don-vip

Milestone: 14.02

comment:12 Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Looks fine.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.