Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#9518 closed enhancement (fixed)

Automatically reload local config files when changed

Reported by: naoliv Owned by: team
Priority: normal Milestone: 14.06
Component: Core Version:
Keywords: Cc:

Description

It would be nice if JOSM could automatically reload local config files (validator .cfg or .mapcss, for example) when they get modified (using some file notification system for this).

Attachments (0)

Change History (14)

comment:1 Changed 6 years ago by simon04

Milestone: 14.05

comment:2 Changed 6 years ago by Klumbumbus

That would be very helpful. When you edit and test mappaint styles, you always need to restart JOSM or delete and re add the style to JOSM after every little change to see the result. That is a bit annoying.

comment:3 Changed 6 years ago by Don-vip

Concerning map styles, there is already a mechanism with mappaint.auto_reload_local_styles in the Map Paint dialog, which can be replaced by a generic WatchService approach.

comment:4 in reply to:  3 Changed 6 years ago by Klumbumbus

Replying to Don-vip:

Concerning map styles, there is already a mechanism with mappaint.auto_reload_local_styles in the Map Paint dialog.

Thanks for the hint, that helps a lot. Though this does only work if the dialog is displayed in the sidebar.

comment:5 Changed 6 years ago by Don-vip

Yes I plan to replace this feature by a better mechanism. But I'll keep the preference entry.

comment:6 Changed 5 years ago by Don-vip

Milestone: 14.0514.06

comment:7 Changed 5 years ago by Don-vip

In 7185/josm:

see #9518 - Automatically reload local styles using new Java 7 WatchService API

comment:8 Changed 5 years ago by Don-vip

In 7188/josm:

see #9518, see #10078 - add debug message for ignored events

comment:9 Changed 5 years ago by naoliv

It still doesn't apply to local MapCSS validator files, right?

comment:10 Changed 5 years ago by Don-vip

Not yet, work in progress :)

comment:11 Changed 5 years ago by Don-vip

Ticket #10188 has been marked as a duplicate of this ticket.

comment:12 Changed 5 years ago by Don-vip

In 7275/josm:

see #9518 - refactor internals of MapCSSTagChecker to prepare later work, improve javadoc

comment:13 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7276/josm:

fix #9518 - Automatically reload MapCSS tagchecker validator rules (configurable with validator.auto_reload_local_rules property), improve javadoc

comment:14 Changed 5 years ago by Don-vip

Ticket #6046 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.