Modify

Opened 5 years ago

Closed 5 years ago

#9432 closed defect (fixed)

error message from terracer-plugin

Reported by: brogo Owned by: team
Priority: major Milestone:
Component: Plugin terracer Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Select a building
  2. press shift+T
  3. Enter "4" on "Abschnitte" (4th field)
  4. Hit OK

What is the expected result?
Splitted building.

What happens instead?
Error message with option to deactivate terracer-plugin, but if canceled the building is splitted correct.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-12-14 02:35:00
Last Changed Author: Don-vip
Revision: 6472
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-12-11 20:56:11 +0100 (Wed, 11 Dec 2013)
Last Changed Rev: 6472

Identification: JOSM/1.5 (6472 de) Windows 7 64-Bit
Memory Usage: 223 MB / 1778 MB (79 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx2000M]
Dataset consistency test: No problems found

Plugin: DirectUpload (30060)
Plugin: FixAddresses (29971)
Plugin: HouseNumberTaggingTool (29854)
Plugin: OpeningHoursEditor (30117)
Plugin: PicLayer (29854)
Plugin: RoadSigns (30034)
Plugin: buildings_tools (30057)
Plugin: editgpx (29854)
Plugin: notes (v0.7)
Plugin: openstreetbugs (30004)
Plugin: pbf (29854)
Plugin: print (29854)
Plugin: reltoolbox (29854)
Plugin: reverter (30031)
Plugin: terracer (30072)
Plugin: undelete (29854)
Plugin: utilsplugin2 (30017)
Plugin: waydownloader (29908)
Plugin: wayselector (29854)

java.lang.IllegalArgumentException: Parameter 'tagsOfPrimitives' must not be null
	at org.openstreetmap.josm.tools.CheckParameterUtil.ensureParameterNotNull(CheckParameterUtil.java:79)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.launchIfNecessary(CombinePrimitiveResolverDialog.java:489)
	at terracer.TerracerAction$1.executeCommand(TerracerAction.java:469)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:42)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:65)
	at terracer.TerracerAction.terraceBuilding(TerracerAction.java:462)
	at terracer.HouseNumberInputHandler.actionPerformed(HouseNumberInputHandler.java:312)
	at terracer.HouseNumberInputDialog.buttonAction(HouseNumberInputDialog.java:241)
	at org.openstreetmap.josm.gui.ExtendedDialog$1.actionPerformed(ExtendedDialog.java:320)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicRootPaneUI$Actions.actionPerformed(Unknown Source)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:493)
	at terracer.HouseNumberInputDialog.<init>(HouseNumberInputDialog.java:122)
	at terracer.HouseNumberInputHandler.<init>(HouseNumberInputHandler.java:86)
	at terracer.TerracerAction.actionPerformed(TerracerAction.java:236)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
...<snip>...

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Don-vip

Ticket #9431 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by skyper

Ticket #9436 has been marked as a duplicate of this ticket.

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o30127].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.