Modify

Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#9362 closed defect (fixed)

Validator dialog not filled with warning messages after cancelling the upload popup window

Reported by: jphilipz Owned by: team
Priority: normal Milestone: 13.12
Component: Core validator Version:
Keywords: Cc:

Description (last modified by mkoniecz)

I have noticed recently that when i upload if the warning dialog shows up and i press cancel, the validation results opens up but its empty, i have to have the dialog appear again and cancel it again for the 'warnings' list to appear.

Attachments (0)

Change History (13)

comment:1 Changed 6 years ago by mkoniecz

  • please, create separate tickets for separate issues
  • roof: add "layer=1", special cases (assuming that building=roof implies "layer=1") are evil
Last edited 6 years ago by mkoniecz (previous) (diff)

comment:2 Changed 6 years ago by jphilipz

Sorry about that, as both these warning issues happened in 1 upload attempt, so i submitted them together, will try better to not this mistake again. AYes looking over the osm wiki, layer=1 should be included with building=roof, hopefully the error wont popup when i do this.

comment:3 Changed 6 years ago by mkoniecz

Can you post three first paragraphs of the text appearing after selecting "Show Status Report" in "Help" menu? I am unable to reproduce this, maybe you have old JOSM version?

Roof problem rereported as #9376 ("For building=roof without layer tag, intersecting with roads, footways, cycleways etc validator should mention that typical roof is above other objects and it should have "layer=1" tag")

Last edited 6 years ago by mkoniecz (previous) (diff)

comment:4 Changed 6 years ago by mkoniecz

Description: modified (diff)

comment:5 Changed 6 years ago by jphilipz

I'm running the stable version. This has only popped up recently in the last month or two. Is there any place to download old versions, so i can check which version it wasnt in.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-11-16 02:34:34
Last Changed Author: simon04
Revision: 6388
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-11-15 22:19:40 +0100 (Fri, 15 Nov 2013)
Last Changed Rev: 6388

Identification: JOSM/1.5 (6388 en) Windows XP 32-Bit
Memory Usage: 40 MB / 247 MB (14 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) Client VM

Plugin: undelete (29854)

comment:6 Changed 6 years ago by jphilipz

Well i tried out the latest development build and the problem isnt there.

comment:7 Changed 6 years ago by Don-vip

Problem is still here as we did'nt do anything on the subject neither. Reproduced with:

Revision: 6432
Repository Root: http://josm.openstreetmap.de/svn
Last Changed Author: Don-vip
Last Changed Date: 2013-12-02 00:54:07 +0100 (Mon, 02 Dec 2013)
Build-Date: 2013-12-03 02:34:45
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 6432

comment:8 Changed 6 years ago by Don-vip

Component: CoreCore validator
Summary: warning messagesValidator dialog not filled with warning messages after cancelling the upload popup window

comment:9 Changed 6 years ago by Don-vip

Likely a regression introduced in r6331 (see #9205).

comment:10 Changed 6 years ago by jphilipz

No its still there in the latest development build and showed up when i had a maxspeed warning message. So here is how i was able to reproduce the bug.

1] startup josm with the validation window closed.
2] draw a 2-node way
3] upload changes
4] warning dialog appears for untagged ways
5] press cancel or esc for dialog to disappear
6] validation window appears empty

If the validation window is open when you upload, the warning list will appear. So are there any download links for old versions, so i can test.

comment:11 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6436/josm:

fix #9362 - Validator dialog not filled with warning messages after cancelling the upload popup window

comment:12 Changed 6 years ago by Don-vip

Milestone: 13.12 (6502)

comment:13 Changed 2 years ago by stoecker

Milestone: 13.12 (6502)13.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.