Modify

Opened 8 years ago

Closed 7 years ago

#9300 closed enhancement (duplicate)

detect nodes with missing railway=crossing

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: railway crossing Cc:

Description (last modified by skyper)

A - node that may be left by pedestrians in at least two directions. Naive check for eligible ways: highway=footway or highway=path or (highway=cycleway and (foot=yes or foot=designed))
B - node that may be left by cyclists in at least two directions. Naive check for eligible ways: highway=cycleway or ((highway=path or highway=footway) and (bicycle=yes or bicycle=designed))
C - node that may be left by railway vehicles in two directions. Check: railway=*

Validator should find all nodes that fulfill following rule: (A OR B) AND C AND NOT railway=crossing

Example of edit fixing problem: osmwww:browse/changeset/18795279

Repository Root: http://josm.openstreetmap.de/svn

Build-Date: 2013-11-09 02:35:12
Last Changed Author: Don-vip
Revision: 6381
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-11-08 14:41:01 +0100 (Fri, 08 Nov 2013)
Last Changed Rev: 6381

Identification: JOSM/1.5 (6381 en_GB) Windows 7 32-Bit
Memory Usage: 94 MB / 247 MB (31 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (29854)
Plugin: notes (v0.6)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by mkoniecz

Description: modified (diff)

comment:2 Changed 8 years ago by skyper

Description: modified (diff)
Keywords: railway crossing added

comment:3 Changed 8 years ago by simon04

Those "missing *=crossing" test ticket should be fixable with our Help/Validator/MapCSSTagChecker by using Help/Styles/MapCSSImplementation#Parentselector. Since custom MapCSS tagchecks can be added in the preferences, creating such tests does not require a development setup. We're happy to get patches.

comment:4 Changed 7 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11270.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.