Modify

Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#9220 closed defect (fixed)

toggle action menuitems not working when clicked

Reported by: aceman Owned by: Don-vip
Priority: normal Milestone: 13.11
Component: Core Version: latest
Keywords: Cc:

Description

The "wireframe" and "expert mode" menuitems do nothing when clicked on. They work when toggled with their respective shortcut keys (e.g. Ctrl-W).

Attachments (0)

Change History (10)

comment:1 Changed 6 years ago by bastiK

Please add your system details (Help > Status report) and add a screenshot of the menu.

comment:2 Changed 6 years ago by skyper

Confirmed, all check boxes in menu "view" do not work.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-10-16 01:34:20
Last Changed Author: xeen
Revision: 6320
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-10-15 09:44:39 +0200 (Tue, 15 Oct 2013)
Last Changed Rev: 6320

Identification: JOSM/1.5 (6320 en) Linux Debian GNU/Linux 7.2 (wheezy)
Memory Usage: 155 MB / 672 MB (82 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u25-2.3.10-1~deb7u1
VM arguments: [-Djosm.home=/home/gast/.test]
Program arguments: [--language=en]
Dataset consistency test: No problems found

comment:3 Changed 6 years ago by aceman

I'm on Linux 32bit, Java 7u40, JOSM 6320. Thanks for confirmation skyper.

comment:4 Changed 6 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

Regression confirmed on Windows as well. Likely caused by r6220.

comment:5 Changed 6 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 6327/josm:

fix #9220 - toggle actions not usable via menu items (regression from r6220)

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: closedreopened

It doesn't work with Changeset manager window toggle action.

comment:7 Changed 6 years ago by Don-vip

Summary: wireframe and expert mode menuitems not working when clickedtoggle action menuitems not working when clicked

comment:8 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 6338/josm:

fix #9220 - fix toggle actions for good

comment:9 Changed 6 years ago by Don-vip

Milestone: 13.11 (6383)

comment:10 Changed 2 years ago by stoecker

Milestone: 13.11 (6383)13.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.